show ipv6 ospf spf

Displays OSPFv3 SPF node, table, and tree information.
Syntax
show ipv6 ospf spf { node | table | tree } [ area { A.B.C.D | decimal } ]
Parameters
node
Displays OSPFv3 node information.
table
Specifies a SPF table.
tree
Specifies a SPF tree.
area
Specifies an area.
A.B.C.D
Area address in dotted decimal format.
decimal
Area address in decimal format.
Modes

User EXEC mode

The show ipv6 ospf spf node command displays the following information:

Output field

Description

SPF node

Each SPF node is identified by its device ID (IPv4 address). If the node is a child node, it is additionally identified by an interface on which the node can be reached appended to the router ID in the format router-id :interface-id .

Cost

The cost of traversing the SPF node to reach the destination.

Hops

The number of hops needed to reach the parent SPF node.

Next Hops to Node

The IPv6 address of the next hop-router or the router interface through which to access the next-hop router.

Parent Nodes

The SPF node’s parent nodes. A parent node is an SPF node at the highest level of the SPF tree, which is identified by its router ID.

Child Nodes

The SPF node’s child nodes. A child node is an SPF node at a lower level of the SPF tree, which is identified by its router ID and interface on which the node can be reached.

The show ipv6 ospf spf table command displays the following information:

Output field

Description

Destination

The destination of a route, which is identified by the following:

  • "R", which indicates the destination is a router. "N", which indicates the destination is a network.
  • An SPF node’s device ID (IPv4 address). If the node is a child node, it is additionally identified by an interface on which the node can be reached appended to the router ID in the format router-id :interface-id .

Bits

A bit that indicates the capability of the device. The bit can be set to one of the following:

  • B - The device is an area border router.
  • E - The device is an AS boundary router.
  • V - The device is a virtual link endpoint.
  • W - The device is a wildcard multicast receiver.

Options

A 24-bit field that enables IPv6 OSPF routers to support the optional capabilities. When set, the following bits indicate the following:

V6 - The router should be included in IPv6 routing calculations.

E - The router floods AS-external-LSAs as described in RFC 2740.

MC - The router forwards multicast packets as described in RFC 1586.

N - The router handles type 7 LSAs as described in RFC 1584.

R - The originator is an active router.

DC -The router handles demand circuits.

Cost

The cost of traversing the SPF node to reach the destination.

Next hop

The IPv6 address of the next hop-router.

Interface

The router interface through which to access the next-hop router.

Examples

The following example shows information about SPF nodes.

device> show ipv6 ospf spf node

SPF node for Area 0.0.0.200
 SPF node 192.168.98.213,  cost: 0,  hops: 0
  nexthops to node:
  parent nodes: 
  child nodes: 192.168.98.111:136 192.168.98.111:1156 
 SPF node 192.168.98.111:136,  cost: 1,  hops: 1
  nexthops to node:    :: e 4/3/1
  parent nodes: 192.168.98.213 
  child nodes: 192.168.98.111:0 
 SPF node 192.168.98.111:1156,  cost: 1,  hops: 1
  nexthops to node:    :: ve 17 
  parent nodes: 192.168.98.213 
  child nodes: 192.168.98.111:0 
 SPF node 192.168.98.111:0,  cost: 1,  hops: 2
  nexthops to node:    fe80::768e:f8ff:fe3e:1800 e 4/3/1
                       fe80::768e:f8ff:fe3e:1800 ve 17 
  parent nodes: 192.168.98.111:136 192.168.98.111:1156 
  child nodes: 
SPF node for Area 400
 SPF node 192.168.98.213,  cost: 0,  hops: 0                      
  nexthops to node:
  parent nodes: 
  child nodes: 
SPF node for Area 0.0.0.0
 SPF node 192.168.98.213,  cost: 0,  hops: 0
  nexthops to node:
  parent nodes: 
  child nodes: 192.168.98.111:0 
 SPF node 192.168.98.111:0,  cost: 1,  hops: 1
  nexthops to node:    5100::192:113:111:111 VLink 1
  parent nodes: 192.168.98.213 
  child nodes: 192.168.98.61:5 192.168.98.190:1551 192.168.98.112:643 
 SPF node 192.168.98.61:5,  cost: 2,  hops: 2
  nexthops to node:    5100::192:113:111:111 VLink 1
  parent nodes: 192.168.98.111:0 
  child nodes: 192.168.98.61:0 
 SPF node 192.168.98.190:1551,  cost: 2,  hops: 2
  nexthops to node:    5100::192:113:111:111 VLink 1
--More--, next page: Space, next line: Return key, 

The following example shows information about SPF nodes in area 0.

device> show ipv6 ospf spf node area 0

SPF node for Area 0
SPF node 10.223.223.223,  cost: 0,  hops: 0
 nexthops to node:
 parent nodes:
 child nodes: 10.223.223.223:88
SPF node 10.223.223.223:88,  cost: 1,  hops: 1
 nexthops to node:    :: ethe 1/3/2
 parent nodes: 10.223.223.223
 child nodes: 10.1.1.1:0
SPF node 10.1.1.1:0,  cost: 1,  hops: 2
 nexthops to node:    fe80::2e0:52ff:fe91:bb37 ethe 1/3/2
 parent nodes: 10.223.223.223:88
 child nodes:

The following example displays the SPF table for area 0.

device> show ipv6 ospf spf table area 0

SPF table for Area 0.0.0.200
  Destination          Bits Options  Cost  Nexthop                   Interface
R 192.168.98.111      --V-B V6E---R-   1  fe80::768e:f8ff:fe3e:1800 e 4/3/1
R 192.168.98.111      --V-B V6E---R-   1  fe80::768e:f8ff:fe3e:1800 ve 17 
N 192.168.98.111[136] ----- V6E---R-   1  ::                        e 4/3/1
N 192.168.98.111[1156 ----- V6E---R-   1  ::                        ve 17 
 SPF table for Area 400
  Destination           Bits Options  Cost  Nexthop                  Interface
 SPF table for Area 0.0.0.0
  Destination           Bits Options  Cost  Nexthop                  Interface
R 192.168.98.71       ---E- V6E---RD   4  fe80::768e:f8ff:fe3e:1800 e 4/3/1
R 192.168.98.71       ---E- V6E---RD   4  fe80::768e:f8ff:fe3e:1800 ve 17 
R 192.168.98.190      ---E- V6E---R-   2  fe80::768e:f8ff:fe3e:1800 e 4/3/1
R 192.168.98.190      ---E- V6E---R-   2  fe80::768e:f8ff:fe3e:1800 ve 17 

The following example displays the SPF tree for area 0.

device> show ipv6 ospf spf tree area 0

   SPF tree for Area 0
 +- 10.223.223.223 cost 0
     +- 10.223.223.223:88 cost 1
         +- 10.1.1.1:0 cost 1
History