show ipv6 ospf database

Displays lists of information about different OSPFv3 link-state advertisements (LSAs).
Syntax
show ipv6 ospf database [ advrtr A.B.C.D | extensive | link-id decimal | prefix ipv6-addr ]
show ipv6 ospf database [ as-external | inter-prefix | inter-router | intra-prefix | link [ decimal ] | network | router | type-7 ] [ advrtr A.B.C.D | link-id decimal ]
show ipv6 ospf database scope { area { A.B.C.D | decimal } | as | link }
show ipv6 ospf database summary
Parameters
advrtr A.B.C.D
Displays LSAs by Advertising Router Id in dotted decimal format.
extensive
Displays detailed lists of LSA information.
link-id decimal
Link-state ID that differentiates LSAs. Valid values range from 1 through 4294967295.
prefix
Display LSAs that contain a prefix.
ipv6-addr
Specifies an IPv6 address.
as-external
Displays information about external LSAs.
inter-prefix
Displays information about inter area prefix LSAs.
inter-router
Displays information about inter area router LSAs.
intra-prefix
Displays information about intra area prefix LSAs.
link decimal
Displays information about the link LSAs.
network
Displays information about network LSAs.
router
Displays information about router LSAs.
type-7
Displays information about the not so stubby area (NSSA) external LSAs.
scope
Displays LSA information by LSA scope.
area
Displays LSAs by scope within a specified area.
as
Displays autonomous system (AS) LSAs by scope.
link
Displays link LSAs by scope.
summary
Displays LSA summary information.
Modes

User EXEC mode

The show ipv6 ospf database command displays the following information:

Output field

Description

Area ID

The OSPF area in which the device resides.

Type

Type of LSA. LSA types can be the following:

  • Rtr - Router LSAs (Type 1).
  • Net - Network LSAs (Type 2).
  • Inap - Inter-area prefix LSAs for ABRs (Type 3).
  • Inar - Inter-area router LSAs for ASBRs (Type 4).
  • Extn - AS external LSAs (Type 5).
  • Link - Link LSAs (Type 8).
  • Iap - Intra-area prefix LSAs (Type 9).

LS ID

The ID of LSA in Decimal.

Adv Rtr

The device that advertised the route.

Seq(Hex)

The sequence number of the LSA. The OSPF neighbor that sent the LSA stamps it with a sequence number to enable the device and other OSPF routers to determine which LSA for a given route is the most recent.

Age

The age of the LSA, in seconds.

Chksum

A checksum for the LSA packet. The checksum is based on all the fields in the packet except the age field. The device uses the checksum to verify that the packet is not corrupted.

Len

The length, in bytes, of the LSA.

Sync

Sync status with the slave management processor (MP).

The show ipv6 ospf database extensive command displays the following information:

Output field

Description

Router LSA (Type 1) (Rtr) Fields

Capability Bits

A bit that indicates the capability of the device. The bit can be set to one of the following:

B - The device is an area border router.

E - The device is an AS boundary router.

V - The device is a virtual link endpoint.

W - The device is a wildcard multicast receiver.

Options

A 24-bit field that enables IPv6 OSPF routers to support the optional capabilities. When set, the following bits indicate the following:

V6 - The device should be included in IPv6 routing calculations.

E - The device floods AS-external-LSAs as described in RFC 2740.

MC - The device forwards multicast packets as described in RFC 1586.

N - The device handles type 7 LSAs as described in RFC 1584.

R - The originator is an active router.

DC -The device handles demand circuits.

Type

The type of interface. Possible types can be the following:

Point-to-point - A point-to-point connection to another router.

Transit - A connection to a transit network.

Virtual link - A connection to a virtual link.

Metric

The cost of using this router interface for outbound traffic.

Interface ID

The ID assigned to the router interface.

Neighbor Interface ID

The interface ID that the neighboring router has been advertising in hello packets sent on the attached link.

Neighbor Router ID

The router ID (IPv4 address) of the neighboring router that advertised the route. (By default, the router ID is the IPv4 address configured on the lowest numbered loopback interface. If the device does not have a loopback interface, the default router ID is the lowest numbered IPv4 address configured on the device.)

Network LSA (Type 2) (Net) Fields

Options

A 24-bit field that enables IPv6 OSPF routers to support the optional capabilities. When set, the following bits indicate the following:

V6 - The device should be included in IPv6 routing calculations.

E - The device floods AS-external-LSAs as described in RFC 2740.

MC - The device forwards multicast packets as described in RFC 1586.

N - The device handles type 7 LSAs as described in RFC 1584.

R - The originator is an active router.

DC -The device handles demand circuits.

Attached Router

The address of the neighboring router that advertised the route.

Inter-Area Prefix LSA (Type 3) (Inap) Fields

Metric

The cost of the route.

Prefix Options

An 8-bit field describing various capabilities associated with the prefix.

Prefix

The IPv6 prefix included in the LSA.

Inter-Area Router LSA (Type 4) (Inar) Fields

Options

A 24-bit field that enables IPv6 OSPF routers to support the optional capabilities. When set, the following bits indicate the following:

V6 - The device should be included in IPv6 routing calculations.

E - The device floods AS-external-LSAs as described in RFC 2740.

MC - The device forwards multicast packets as described in RFC 1586.

N - The device handles type 7 LSAs as described in RFC 1584.

R - The originator is an active router.

DC -The device handles demand circuits.

Metric

The cost of the route.

Destination Router ID

The ID of the router described in the LSA.

AS External LSA (Type 5) (Extn) Fields

Bits

The bit can be set to one of the following:

  • E - If bit E is set, a Type 2 external metric. If bit E is zero, a Type 1 external metric.
  • F - A forwarding address is included in the LSA.
  • T - An external route tag is included in the LSA.

Metric

The cost of this route, which depends on bit E.

Prefix Options

An 8-bit field describing various capabilities associated with the prefix.

Referenced LS Type

If non-zero, an LSA with this LS type is associated with the LSA.

Prefix

The IPv6 prefix included in the LSA.

Link LSA (Type 8) (Link) Fields

Router Priority

The router priority of the interface attaching the originating router to the link.

Options

The set of options bits that the router would like set in the network LSA that will be originated for the link.

Link Local Address

The originating router’s link-local interface address on the link.

Number of Prefix

The number of IPv6 address prefixes contained in the LSA.

Prefix Options

An 8-bit field of capabilities that serve as input to various routing calculations:

  • NU - The prefix is excluded from IPv6 unicast calculations.
  • LA - The prefix is an IPv6 interface address of the advertising router.
  • MC - The prefix is included in IPv6 multicast routing calculations.
  • P - NSSA area prefixes are readvertised at the NSSA area border.

Prefix

The IPv6 prefix included in the LSA.

Intra-Area Prefix LSAs (Type 9) (Iap) Fields

Number of Prefix

The number of prefixes included in the LSA.

Referenced LS Type, Referenced LS ID

Identifies the router-LSA or network-LSA with which the IPv6 address prefixes are associated.

Referenced Advertising Router

The address of the neighboring router that advertised the route.

Prefix Options

An 8-bit field describing various capabilities associated with the prefix.

Metric

The cost of using the advertised prefix.

Prefix

The IPv6 prefix included in the LSA.

Number of Prefix

The number of prefixes included in the LSA.

Examples

The following example shows sample output from the show ipv6 ospf database command.

device> show ipv6 ospf database

LSA Key - Rtr:Router Net:Network Inap:InterPrefix Inar:InterRouter
          Extn:ASExternal Grp:GroupMembership Typ7:Type7 Link:Link
          Iap:IntraPrefix Grc:Grace
Area ID         Type LSID       Adv Rtr         Seq(Hex) Age  Cksum Len   Sync
0.0.0.200       Link 897        192.168.98.213  80000007 1277 9044  64    Yes 
0.0.0.200       Link 136        192.168.98.111  80000007 582  fb0b  64    Yes 
0.0.0.200       Link 2049       192.168.98.213  80000006 1277 381a  64    Yes 
0.0.0.200       Link 1156       192.168.98.111  80000007 582  cf38  64    Yes 
0.0.0.200       Link 2052       192.168.98.213  80000004 799  5b06  64    Yes 
0.0.0.200       Rtr  0          192.168.98.111  800002ea 823  cb7b  56    Yes 
0.0.0.200       Rtr  0          192.168.98.213  800001c7 799  8402  56    Yes 
0.0.0.200       Net  1156       192.168.98.111  80000004 823  b2d2  32    Yes 
0.0.0.200       Net  136        192.168.98.111  80000008 823  aed2  32    Yes 
N/A             Extn 0000021d   10.223.223.223 	800000a8 1319 441e  32   	Yes 

The following example shows sample output from the show ipv6 ospf database command when the advr keyword is used.

device> show ipv6 ospf database advr 192.168.98.111

LSA Key - Rtr:Router Net:Network Inap:InterPrefix Inar:InterRouter
          Extn:ASExternal Grp:GroupMembership Typ7:Type7 Link:Link
          Iap:IntraPrefix Grc:Grace
Area ID         Type LSID       Adv Rtr         Seq(Hex) Age  Cksum Len   Sync
0.0.0.200       Link 136        192.168.98.111  80000007 634  fb0b  64    Yes 
     Router Priority: 1
     Options: V6E---R--
     LinkLocal Address: fe80::768e:f8ff:fe3e:1800
     Number of Prefix: 1
     Prefix Options: 
     Prefix: 5100::193:213:111:0/112

The following example shows sample output from the show ipv6 ospf database command when the as-external keyword is used.

device> show ipv6 ospf database as-external

LSA Key - Rtr:Router Net:Network Inap:InterPrefix Inar:InterRouter
          Extn:ASExternal Grp:GroupMembership Typ7:Type7 Link:Link
          Iap:IntraPrefix Grc:Grace
Area ID         Type LSID       Adv Rtr         Seq(Hex) Age  Cksum Len   Sync
N/A             Extn 2          192.168.98.213  80000004 895  6e5e  44    Yes 
     Bits: E--
     Metric: 0
     Prefix Options: 
     Referenced LSType: 0
     Prefix: 5100:213:213:0:192:213:1:0/112
LSA Key - Rtr:Router Net:Network Inap:InterPrefix Inar:InterRouter
          Extn:ASExternal Grp:GroupMembership Typ7:Type7 Link:Link
          Iap:IntraPrefix Grc:Grace
Area ID         Type LSID       Adv Rtr         Seq(Hex) Age  Cksum Len   Sync
N/A             Extn 1          192.168.98.190  80001394 643  1cc9  28    Yes 
     Bits: E--
     Metric: 1
     Prefix Options: 
     Referenced LSType: 0
     Prefix: ::/0                                                 
LSA Key - Rtr:Router Net:Network Inap:InterPrefix Inar:InterRouter
          Extn:ASExternal Grp:GroupMembership Typ7:Type7 Link:Link
          Iap:IntraPrefix Grc:Grace
Area ID         Type LSID       Adv Rtr         Seq(Hex) Age  Cksum Len   Sync
N/A             Extn 2          192.168.98.71   80000258 132  a3ff  32    Yes 
     Bits: E-T
     Metric: 1
     Prefix Options: 
     Referenced LSType: 0
     Prefix: ::/0
     Tag: 1

The following example shows sample output from the show ipv6 ospf database command when the extensive keyword is used.

device> show ipv6 ospf database extensive

LSA Key - Rtr:Router Net:Network Inap:InterPrefix Inar:InterRouter
          Extn:ASExternal Grp:GroupMembership Typ7:Type7 Link:Link
          Iap:IntraPrefix Grc:Grace
Area ID      Type LS ID    Adv Rtr         Seq(Hex) Age  Cksum Len  Sync
0.0.0.200    Link 897      192.168.98.213  80000007 1432 9044  64    Yes 
     Router Priority: 1
     Options: V6E---R--
     LinkLocal Address: fe80::214:ff:fe77:96ff
     Number of Prefix: 1
     Prefix Options: 
     Prefix: 5100::193:213:111:0/112
LSA Key - Rtr:Router Net:Network Inap:InterPrefix Inar:InterRouter
          Extn:ASExternal Grp:GroupMembership Typ7:Type7 Link:Link
          Iap:IntraPrefix Grc:Grace
Area ID      Type LSID     Adv Rtr         Seq(Hex) Age  Cksum Len   Sync
0.0.0.200    Link 136      192.168.98.111  80000007 737  fb0b  64    Yes 
     Router Priority: 1
     Options: V6E---R--
     LinkLocal Address: fe80::768e:f8ff:fe3e:1800
--More--, next page: Space, next line: Return key, quit: Control-c
History