show ip traffic

Displays IP traffic statistics.
Syntax
show ip traffic
Modes

User EXEC mode

The show ip traffic command displays the following information:

Output Field Description

IP Statistics

received

The total number of IP packets received by the device.

sent

The total number of IP packets originated and sent by the device.

forwarded The total number of forwarded IP packets.
filtered The total number of filtered IP packets.

fragmented

The total number of IP packets fragmented by this device to accommodate the MTU of this device or of another device.

reassembled

The total number of fragmented IP packets that this device re-assembled.

bad header

The number of IP packets dropped by the device due to a bad packet header.

no route

The number of packets dropped by the device because there was no route.

unknown proto

The number of packets dropped by the device because the value in the Protocol field of the packet header is unrecognized by this device.

no buffer

This information is used by RUCKUS Technial Support.

other errors

The number of packets that this device dropped due to error types other than the types listed previously.

ICMP Statistics

The ICMP statistics are derived from RFC 792, "Internet Control Message Protocol", RFC 950, "Internet Standard Subnetting Procedure", and RFC 1256, "ICMP Router Discovery Messages". Statistics are organized into Sent and Received.The following field descriptions apply to each statistic.

total

The total number of ICMP messages sent or received by the device.

errors

This information is used by RUCKUS Technical Support.

unreachable

The number of Destination Unreachable messages sent or received by the device.

time exceed

The number of Time Exceeded messages sent or received by the device.

parameter

The number of Parameter Problem messages sent or received by the device.

source quench

The number of Source Quench messages sent or received by the device.

redirect

The number of Redirect messages sent or received by the device.

echo

The number of Echo messages sent or received by the device.

echo reply

The number of Echo Reply messages sent or received by the device.

timestamp

The number of Timestamp messages sent or received by the device.

timestamp reply

The number of Timestamp Reply messages sent or received by the device.

addr mask

The number of Address Mask Request messages sent or received by the device.

addr mask reply

The number of Address Mask Replies messages sent or received by the device.

irdp advertisement

The number of ICMP Router Discovery Protocol (IRDP) Advertisement messages sent or received by the device.

irdp solicitation

The number of IRDP Solicitation messages sent or received by the device.

UDP Statistics

received

The number of UDP packets received by the device.

sent

The number of UDP packets sent by the device.

no port

The number of UDP packets dropped because the packet did not contain a valid UDP port number.

input errors

This information is used by RUCKUS Technical Support.

no data

Total number of UDP Packets received with no data .

TCP Statistics

The TCP statistics are derived from RFC 793, "Transmission Control Protocol".

current active tcbs

The number of TCP Control Blocks (TCBs) that are currently active.

tcbs allocated

The number of TCBs that have been allocated.

tcbs freed

The number of TCBs that have been freed.

tcbs protected

This information is used by RUCKUS Technical Support.

active opens

The number of TCP connections opened by this device by sending a TCP SYN to another device.

passive opens

The number of TCP connections opened by this device in response to connection requests (TCP SYNs) received from other devices.

failed attempts

This information is used by RUCKUS Technical Support.

active resets

The number of TCP connections this device reset by sending a TCP RESET message to the device at the other end of the connection.

passive resets

The number of TCP connections this device reset because the device at the other end of the connection sent a TCP RESET message.

input errors

This information is used by RUCKUS Technical Support.

in segments

The number of TCP segments received by the device.

out segments

The number of TCP segments sent by the device.

retransmission

The number of segments that this device retransmitted because the retransmission timer for the segment had expired before the device at the other end of the connection had acknowledged receipt of the segment.

in connections requests

The number of connection requests received by the device.

out connections requests

The number of connection requests sent by the device.

connections established

The total number of TCP connections established.

acks

The total number acknowledgments received.

duplicate acks

The total number of duplicate acknowledgments received.

duplicate bytes

The total number of TCP packets received with duplicate sequence numbers.

bad checksum

The total number of TCP packets received with a bad checksum.

no checksum

The total number of TCP packets received with no checksum.

invalid header length

The total number of TCP packets received where the header length is less than the minimum header length.

illegal TCP MSS option length

The total number of TCP packets received with an illegal TCP MSS option length.

illegal option

The total number of TCP packets received with an illegal kind of TCP option.

minimum TCP header

The total number of TCP packets received with the length of the packet less than the minimum TCP header length requirement.

invalid segment

TCP invalid segments received.

Examples

The following example shows sample output from the show ip traffic command.

device> show ip traffic
IP Statistics
  9423729 received, 34650 sent, 0 forwarded
  0 filtered, 0 fragmented, 0 reassembled, 0 bad header
  0 no route, 0 unknown proto, 0 no buffer, 2477 other errors
 
ARP Statistics
  5169915 total recv, 1970178 req recv, 32159 req sent, 1761422 rep sent
  0 pending drop, 0 invalid source, 0 invalid dest
  0 mis-match dst-mac, 0 mis-match ip addr, 0 mis-match src-mac
 
ICMP Statistics
Received:
  2 total, 0 errors, 0 unreachable, 0 time exceed
  0 parameter, 0 source quench, 0 redirect, 0 echo,
  2 echo reply, 0 timestamp, 0 timestamp reply, 0 addr mask
  0 addr mask reply, 0 irdp advertisement, 0 irdp solicitation
Sent:
  29 total, 0 errors, 18 unreachable, 0 time exceed
  0 parameter, 0 source quench, 0 redirect, 11 echo,
  0 echo reply, 0 timestamp, 0 timestamp reply, 0 addr mask
  0 addr mask reply, 0 irdp advertisement, 0 irdp solicitation
 
UDP Statistics
  528301 received, 75777 sent, 1091 no port, 0 input errors, 0 no data

TCP Statistics
  0 active opens, 0 passive opens, 0 failed attempts
  0 active resets, 0 passive resets, 0 input errors
  0 in segments, 0 out segments, 0 retransmission
  0 in connections requests, 4 out connections requests, 0 connections established,
  0 acks, 0  duplicate acks, 0 duplicate bytes
  0 bad checksum, 0 no checksum, 0 invalid header length
  0 illegal TCP MSS option length, 0 illegal option, 0 minimum TCP header, 0 invalid segment
History
Release version Command history
08.0.95 The command output was enhanced to show more detailed information for TCP and User Datagram Protocol (UDP) statistics.