RFC 4273: Definitions of Managed Objects for BGP-4

Note: The definitions of managed objects for BGP-4 is used instead of RFC 1567, Definitions of Managed Objects for the Fourth Version of the Border Gateway Protocol (BGP-4) using SMIv2. RFC 1657 has been obsoleted by RFC 4273.

Object group name

Object identifier

Notes

bgpVersion

1.3.6.1.2.1.15.1

The vector of the supported BGP version numbers.

bgpLocalAS

1.3.6.1.2.1.15.2

The local autonomous system number.

bgpPeerTable

1.3.6.1.2.1.15.3

The bgpPeerRemoteAs object is the remote autonomous system number received in the BGP OPEN message.

bgpPeerEntry

1.3.6.1.2.1.15.3.1

-

bgpPeerIdentifier

1.3.6.1.2.1.15.3.1.1

-

bgpPeerState

1.3.6.1.2.1.15.3.1.2

-

bgpPeerAdminStatus

1.3.6.1.2.1.15.3.1.3

-

bgpPeerNegotiatedVersion

1.3.6.1.2.1.15.3.1.4

-

bgpPeerLocalAddr

1.3.6.1.2.1.15.3.1.5

-

bgpPeerLocalPort

1.3.6.1.2.1.15.3.1.6

-

bgpPeerRemoteAddr

1.3.6.1.2.1.15.3.1.7

-

bgpPeerRemotePort

1.3.6.1.2.1.15.3.1.8

-

bgpPeerRemoteAs

1.3.6.1.2.1.15.3.1.9

-

bgpPeerInUpdates

1.3.6.1.2.1.15.3.1.10

-

bgpPeerOutUpdates

1.3.6.1.2.1.15.3.1.11

-

bgpPeerInTotalMessages

1.3.6.1.2.1.15.3.1.12

-

bgpPeerOutTotalMessages

1.3.6.1.2.1.15.3.1.13

-

bgpPeerLastError

1.3.6.1.2.1.15.3.1.14

-

bgpPeerFsmEstablishedTransitions

1.3.6.1.2.1.15.3.1.15

-

bgpPeerFsmEstablishedTime

1.3.6.1.2.1.15.3.1.16

-

bgpPeerConnectRetryInterval

1.3.6.1.2.1.15.3.1.17

SET operation is not supported.

bgpPeerHoldTime

1.3.6.1.2.1.15.3.1.18

-

bgpPeerKeepAlive

1.3.6.1.2.1.15.3.1.19

-

bgpPeerHoldTimeConfigured

1.3.6.1.2.1.15.3.1.20

-

bgpPeerKeepAliveConfigured

1.3.6.1.2.1.15.3.1.21

-

bgpPeerMinASOriginationInterval

1.3.6.1.2.1.15.3.1.22

SET operation is not supported.

bgpPeerMinRouteAdvertisementInterval

1.3.6.1.2.1.15.3.1.23

-

bgpPeerInUpdateElapsedTime

1.3.6.1.2.1.15.3.1.24

-

bgpIdentifier

1.3.6.1.2.1.15.4

-

bgp4PathAttrTable

1.3.6.1.2.1.15.6

-

bgp4PathAttrEntry

1.3.6.1.2.1.15.6.1

-

bgp4PathAttrPeer

1.3.6.1.2.1.15.6.1.1

-

bgp4PathAttrIpAddrPrefixLen

1.3.6.1.2.1.15.6.1.2

-

bgp4PathAttrIpAddrPrefix

1.3.6.1.2.1.15.6.1.3

-

bgp4PathAttrOrigin

1.3.6.1.2.1.15.6.1.4

-

bgp4PathAttrASPathSegment

1.3.6.1.2.1.15.6.1.5

This object is the sequence of AS path segments. Each AS path segment is represented by a triplet of type , length , and value .

bgp4PathAttrNextHop

1.3.6.1.2.1.15.6.1.6

-

bgp4PathAttrMultiExitDisc

1.3.6.1.2.1.15.6.1.7

-

bgp4PathAttrLocalPref

1.3.6.1.2.1.15.6.1.8

-

bgp4PathAttrAtomicAggregate

1.3.6.1.2.1.15.6.1.9

-

bgp4PathAttrAggregatorAS

1.3.6.1.2.1.15.6.1.10

The AS number of the last BGP4 speaker that performed route aggregation. A value of zero (0) indicates the absence of this attribute.

bgp4PathAttrAggregatorAddr

1.3.6.1.2.1.15.6.1.11

-

bgp4PathAttrCalcLocalPref

1.3.6.1.2.1.15.6.1.12

-

bgp4PathAttrBest

1.3.6.1.2.1.15.6.1.13

-

bgp4PathAttrUnknown

1.3.6.1.2.1.15.6.1.14

-