The following table contains the BGP4v2 Network Layer Reachability Information (NLRI)
objects. Use the
show ip bgp routes detail command to display all the BGP attributes of a route, such as communities. Use the
show ip bgp routes command to display the entries learned through NLRI available in the update.
Name, OID, and syntax
Access
Description
bgp4V2NlriTable
1.3.6.1.4.1.1991.3.5.1.1.9
None
The BGP4v2-received path attribute table contains information about paths to destination
networks received from all the BGP4 peers. Collectively, this represents the Adj-Ribs-In.
For NLRI, the route in which the bgp4V2NlriBest object is true represents the route
that is installed in the LocRib from the Adj-Ribs-In.
bgp4V2NlriIndex
1.3.6.1.4.1.1991.3.5.1.1.9.1.1
Syntax: Unsigned32
None
Specifies the index that allows multiple instances of a base prefix for a certain
AFI-SAFI from a given peer. This is used to allow a peer in future implementations
to send more than a single route instance and allow extensions that extend an NLRI
field to send the same prefix while utilizing other extension-specific information.
The index is always 1.
bgp4V2NlriAfi
1.3.6.1.4.1.1991.3.5.1.1.9.1.2
Syntax: Bgp4V2AddressFamilyIdentifierTC
None
Specifies the address family of the prefix for NLRI.
Note: It is not necessary that an AFI definition is equivalent to an InetAddressType.
bgp4V2NlriSafi
1.3.6.1.4.1.1991.3.5.1.1.9.1.3
Syntax: Bgp4V2SubsequentAddressFamilyIdentifierTC
None
Specifies the subsequent address family of the prefix for NLRI.
bgp4V2NlriPrefixType
1.3.6.1.4.1.1991.3.5.1.1.9.1.4
Syntax: InetAddressType
None
Specifies the type of the IP address prefix in an NLRI field. The value of the object
is derived from the appropriate value from the bgp4V2NlriAfi field. Where an appropriate
InetAddressType is not available, the value of the object is unknown(0).
bgp4V2NlriPrefix
1.3.6.1.4.1.1991.3.5.1.1.9.1.5
Syntax: InetAddress
None
Indicates an IP address prefix in an NLRI field. The object is an IP address containing
the prefix with the length specified by the bgp4V2NlriPrefixLen object. Any bits beyond
the length specified by the bgp4V2NlriPrefixLen object are set to zero(0).
bgp4V2NlriPrefixLen
1.3.6.1.4.1.1991.3.5.1.1.9.1.6
Syntax: InetAddressPrefixLength
None
Indicates the length in bits of the address prefix in an NLRI field.
bgp4V2NlriBest
1.3.6.1.4.1.1991.3.5.1.1.9.1.7
Syntax: TruthVal
Read-only
Indicates whether the route is chosen as the best BGP4 route for the destination.
bgp4V2NlriCalcLocalPref
1.3.6.1.4.1.1991.3.5.1.1.9.1.8
Syntax: Unsigned32
Read-only
Specifies the degree of preference calculated by the receiving BGP4 speaker for an
advertised route.
The value of the object is zero (0) where the prefix is ineligible.
bgp4V2NlriOrigin
1.3.6.1.4.1.1991.3.5.1.1.9.1.9
Syntax: Integer
Read-only
Specifies the ultimate origin of the path information:
igp(1) - The networks that are interior.
egp(2) - The networks learned through an Exterior Gateway Protocol (EGP).
incomplete(3) - The networks that are learned by some other means.
bgp4V2NlriNextHopAddrType
1.3.6.1.4.1.1991.3.5.1.1.9.1.10
Syntax: InetAddressType
Read-only
Specifies the address family of the address for the border router that is used to
access the destination network.
bgp4V2NlriNextHopAddr
1.3.6.1.4.1.1991.3.5.1.1.9.1.11
Syntax: InetAddress
Read-only
Specifies the address of the border router that is used to access the destination
network. The address is the next-hop address received in the update packet associated
with the prefix:
For RFC 2545 style double nexthops, the object contains the global scope next hop.
For bgpPathAttrLinkLocalNextHop, the object contains the link local scope next hop,
if it is present.
For bgp4V2NlriNextHopAddr, the object contains the link local next hop, if a mechanism
is developed to use only a link local next hop.
bgp4V2NlriLinkLocalNextHopAddrType
1.3.6.1.4.1.1991.3.5.1.1.9.1.12
Syntax: InetAddressType
Read-only
Specifies the address type for an IPv6 link local address.
The object is present only when receiving RFC 2545 style double nexthops.
The object is present optionally in BGP implementations that do not support IPv6.
The value of the object is unknown(0) when there is no IPv6 link local next hop present.
bgp4V2NlriLinkLocalNextHopAddr
1.3.6.1.4.1.1991.3.5.1.1.9.1.13
Syntax: InetAddress
Read-only
Indicates the value that contains an IPv6 link local address and is present only when
receiving RFC 2545 style double nexthops.
The object is present optionally in BGP implementations that do not support IPv6.
The length of the object is zero(0) when there is no IPv6 link local next hop present.
bgp4V2NlriLocalPrefPresent
1.3.6.1.4.1.1991.3.5.1.1.9.1.14
Syntax: TruthVal
Read-only
Indicates if the value is true when the LOCAL_PREF value is sent in the UPDATE message.
The value is always true.
bgp4V2NlriLocalPref
1.3.6.1.4.1.1991.3.5.1.1.9.1.15
Syntax: Unsigned32
Read-only
Specifies the degree of preference of the originating BGP4 speaker for an advertised
route.
bgp4V2NlriMedPresent
1.3.6.1.4.1.1991.3.5.1.1.9.1.16
Syntax: TruthVal
Read-only
Indicates if the value is true when a Multi-Exit Discriminator (MED) value is sent
in the UPDATE message.
bgp4V2NlriMed
1.3.6.1.4.1.1991.3.5.1.1.9.1.17
Syntax: Unsigned32
Read-only
Indicates the metric used to discriminate between multiple exit points to an adjacent
autonomous system. When an MED value is absent but has a calculated default value,
the object will contain the calculated value.
bgp4V2NlriAtomicAggregate
1.3.6.1.4.1.1991.3.5.1.1.9.1.18
Syntax: TruthVal
Read-only
Indicates if the value is true when the ATOMIC_AGGREGATE path attribute is present
and indicates that NLRI cannot be made more specific.
bgp4V2NlriAggregatorPresent
1.3.6.1.4.1.1991.3.5.1.1.9.1.19
Syntax: TruthVal
Read-only
Indicates if the value is true when the AGGREGATOR path attribute is sent in the UPDATE
message.
bgp4V2NlriAggregatorAS
1.3.6.1.4.1.1991.3.5.1.1.9.1.20
Syntax: InetAutonomousSystemNumber
Read-only
Specifies an AS number of the last BGP4 speaker that performed route aggregation.
The value of the object is zero(0) when the bgp4V2NlriAggregatorPresent object is
false.
bgp4V2NlriAggregatorAddr
1.3.6.1.4.1.1991.3.5.1.1.9.1.21
Syntax: Bgp4V2IdentifierTC
Read-only
Specifies the IP address of the last BGP4 speaker that performed route aggregation.
The value of the object is 0.0.0.0 when the bgp4V2NlriAggregatorPresent object is
false.
bgp4V2NlriAsPathCalcLength
1.3.6.1.4.1.1991.3.5.1.1.9.1.22
Syntax: Unsigned32
Read-only
Indicates the value that represents the calculated length of the AS-Path according
to the rules in the BGP specification. The value is used in route selection.
bgp4V2NlriAsPathString
1.3.6.1.4.1.1991.3.5.1.1.9.1.23
Syntax: SnmpAdminString
Read-only
Specifies a string depicting the AS-Path to the network, which is received from the
peer that is advertised.
The format of the string is implementation-dependent and it must be designed for operator
readability.
SnmpAdminString is capable of representing a maximum of 255 characters. This may lead
to the string being truncated in the presence of a large AS-Path.
Note: It is recommended that when the content of the object is truncated, the final three
octets should be reserved for the ellipses string (...). The bgp4V2NlriAsPath object
gives access to the full AS-Path.
bgp4V2NlriAsPath
1.3.6.1.4.1.1991.3.5.1.1.9.1.24
Syntax: Octet String
Read-only
Specifies the contents of the BGP4 AS_PATH attribute to provide an authorized form
of the BGP4 AS_PATH along with the human-readable bgp4V2NlriAsPathString object that
can be truncated. The object is parsed using the rules defined for four-octet autonomous
systems as defined in RFC 4893. RFC 4271 and RFC 5065 define the general format of
the AS_PATH attribute and its code points.
The AS_PATH attribute is composed of a sequence of AS segments. Each AS segment is
represented in the following fields:
The path segment type and path segment are one octet in length each. Any one of the
following can represent the path segment type field:
1 - AS_SET (RFC 4721)
2 - AS_SEQUENCE (RFC 4721)
3 - AS_CONFED_SEQUENCE (RFC 3065)
4 - AS_CONFED_SET (RFC 3065)
The path segment length field contains the number of autonomous systems (not the number
of octets) in the path segment value field.
The path segment value field contains one or more autonomous system numbers, each
encoded as a four octet length field in network-byte order.
Note: An SNMP agent can truncate the
objects that are less than its maximum theoretical length of 4072
octets. It is recommended that when such truncation occurs on the
boundary of an encoded AS, the partial AS be discarded from the
object and the object size adjusted accordingly. When such
truncation happens, either alone or in conjunction with the
truncation of a partially encoded AS, it will yield an empty path
segment value. In that case, the path segment type and path segment
length components of the truncated AS_PATH attribute are also
discarded and the object size is adjusted accordingly.
bgp4V2NlriPathAttrUnknown
1.3.6.1.4.1.1991.3.5.1.1.9.1.25
Syntax: Octet String
Read-only
Specifies the path attributes that are not understood by the implementation are presented.
These path attributes use the type, length, and value encoding from RFC 4271.
Note: An SNMP agent can truncate the objects that are less than its maximum theoretical
length of 4072 octets.