RFC 4293: Management Information Base for the Internet Protocol (IP)

RFC 4293, Management Information Base for the Internet Protocol (IP) obsoletes the following:

  • RFC 2011: SNMPv2 Management Information Base for the Internet Protocol using SMIv2
  • RFC 2465: Management Information Base for IP Version 6: Textual Conventions and General Group
  • RFC 2466: Management Information Base for IP Version 6: ICMPv6 Group

The following table summarizes the tables from the RFC that are supported.

Object group name

Object identifier

Supported IP version

Access

IP scalar variables

1.3.6.1.2.1.4

IPv4 and IPv6

Only the following objects have read-write access:

  • ipDefaultTTL
  • ipv6IpDefaultHopLimit
  • ipv6IpForwarding

All other scalar variables are read-only.

Note: GET operation is not supported on the RUCKUSFastIron devices for the ipv6InterfaceTableLastChange scalar object.
ipAddrTable

1.3.6.1.2.1.4.20

IPv4 and IPv6 The table of addressing information relevant to this entity's IP addresses.

This table has been deprecated, as a new IP version-neutral table has been added. It is loosely replaced by the ipAddressTable although several objects that weren't deemed useful weren't carried forward while another (ipAdEntReasmMaxSize) was moved to the ipv4InterfaceTable.

ipNetToMediaTable

1.3.6.1.2.1.4.22

IPv4

All objects are read-only.

ipCidrRouteTable 1.3.6.1.2.1.4.24.4 IPv4 and IPv6

This entity's IP Routing table. This table has been deprecated in favor of the IP version neutral inetCidrRouteTable.

inetCidrRouteTable 1.3.6.1.2.1.4.24.7 IPv4 and IPv6 This entity's IP Routing table.
ipv6InterfaceTable

1.3.6.1.2.1.4.30

IPv6

All objects are read-only.

ipNetToPhysicalTable 1.3.6.1.2.1.4.35    
ipSystemStatsTable
ipIfStatsTableLastChange

Syntax: TimeStamp

1.3.6.1.2.1.4.31.2

IPv4 and IPv6

All objects are read-only.

ipAddressTable

1.3.6.1.2.1.4.34

IPv4 and IPv6

All objects are read-only.

icmp

1.3.6.1.2.1.5

IPv4 and IPv6

 
icmpStatsTable 1.3.6.1.2.1.5.29  

All objects are read-only.

icmpMsgStatsTable 1.3.6.1.2.1.5.30  

All objects are read-only.

tcp 1.3.6.1.2.1.6

IPv4 and IPv6

 
tcpConnTable 1.3.6.1.2.1.6.13

IPv4

 
ipv6TcpConnTable 1.3.6.1.2.1.6.16

IPv6

 
tcpConnectionTable 1.3.6.1.2.1.6.19

IPv4 and IPv6

 
tcpListenerTable 1.3.6.1.2.1.6.20

IPv4 and IPv6

All objects are read-only.

udp 1.3.6.1.2.1.7

IPv4 and IPv6

 
udpTable 1.3.6.1.2.1.7.5

IPv4

All objects are read-only.

ipv6UdpTable 1.3.6.1.2.1.7.6

IPv6

All objects are read-only.

udpEndpointTable 1.3.6.1.2.1.7.7

IPv4 and IPv6

Not-accessible