option
option
option-name
{
ascii
|
hex
|
ip
}
option-valueoption
option-number
{
ascii
|
hex
|
ip
}
ascii
|
bool
|
hex
|
integer
|
ip
}
option-value- option-name
- Specifies the option name. Valid values are:
- associated-ip
- Specifies that all IP addresses associated with a given DHCP client are listed. (Option 92.)
- bcms-controller-address
- Specifies a list of IP addresses for Broadcast and Multicast Service (BCMCS) controllers. Controllers are listed in order of preference. (Option 89.)
- bcms-controller-names
- Specifies a list of Broadcast and Multicast Service (BCMCS) Controller domain names. (Option 88.)
- boot-size
- Specifies the length of the default boot image for the client in 512-octet blocks . (Option 13.)
- cookie-servers
- Specifies the list of RFC 865 cookie servers available to the client. Servers are listed in order of preference. (Option 8.)
- default-ip-ttl
- Specifies the default time-to-live that the client should use on outgoing datagrams. (Option 23.)
- default-tcp-ttl
- Specifies the default TTL that the client should use when sending TCP segments. (Option 37.)
- dhcp-max-message-size
- DHCP maximum message size. Used as default, if not provided by the client. (Option 57.)
- dhcp-message
- This option is used by a DHCP server to provide an error message to a DHCP client in a DHCPNAK message in the event of a failure. (Option 56.)
- dhcp-option-overload
- Indicates the DHCP 'sname' or 'file' fields are overloaded by using them to carry DHCP options. (Option 52.)
- dhcp-parameter-request-list list-of-intergers
- Specifies the options to be sent to the client. (Option 55.)
- dhcp-requested-address
- Specifies an IP address used in a client request (DHCPDISCOVER) to allow the client to request a particular IP address be assigned. (Option 50.)
- domain-name
- Specifies the domain name the client should use when resolving host names using the Domain Name System. (Option 15.)
- domain-name-servers
- Specifies a list of Domain Name System (RFC 1035) name servers available to the client. Servers are listed in order of preference. (Option 6.)
- domain-search
- Specifies a Domain Names search list used by the client to locate not-fully-qualified domain names. (Option 119.)
- extensions-path
- Specifies a file, retrievable through TFTP, that contains information that can be interpreted in the same way as the vendor-extension field within the BOOTP response. (Option 18.)
- finger-server
- Specifies a list of Finger Servers available to the client. Servers are listed in order of preference. (Option 73.)
- font-servers
- Specifies a list of IP addresses of X Window System Font servers available to the client. X Window System Font servers are listed in order of preference. (Option 48.)
- ieee802-3-encapsulation
- Specifies if the client should use Ethernet Version 2 (RFC 894) or IEEE 802. (Option 36.)
- ien116-name-servers
- Specifies a list of Name Servers available to the client. Name Servers are listed in order of preference. (Option 5.)
- impress-servers
- Specifies a list of Imagen Impress Servers available to the client. Servers are listed in order of preference. (Option 10.)
- ip-forwarding
- Specifies if the client should configure its IP layer for packet forwarding. (Option 19.)
- irc-server
- Specifies a list of Internet Relay Chat (IRC) Servers available to the client. Servers are listed in order of priority. (Option 74.)
- log-servers
- Specifies a list of UDP log servers available to the client. Servers are listed in order of preference. (Option 7.)
- lpr-servers
- Specifies a list of Line Printer Servers available to the client. Servers are listed in order of preference. (Option 9.)
- max-dgram-reassembly
- Specifies the maximum size datagram that the client can reassemble. (Option 22.)
- merit-dump
- Specifies the path name of the core file of the client when the client crashes. (Option 14.)
- mobile-ip-home-agent
- Specifies a list of IP addresses for Mobile IP Home Agents available to the client. Agents are listed in order of priority. (Option 68.)
- nds-context
- Specifies the name of the initial Netware Directory Service for an NDS client. (Option 87.)
- nds-servers
- Specifies the IP addresses for Novell Directory Services (NDS) servers available to the client. Servers are listed in order of priority. (Option 85.)
- nds-tree-name string
- Specifies the name of the Novell Directory Services (NDS) Tree to which the client will connect. (Option 86.)
- netbios-dd-server
- Specifies a list of NetBIOS Datagram Distribution Servers (NBDD) servers (RFC 1001 and RFC 1002). NBDD servers are listed in order of preference. (Option 45.)
- netbios-name-servers
- Specifies a list of NetBIOS Name Servers (NBNS) (RFC 1001 and RFC 1002). NBNS servers are listed in order of preference. (Option 44.)
- netbios-scope
- Specifies the NetBIOS over TCP/IP scope parameter (RFC 1001 and RFC 1002) for the client. (Option 47.)
- netinfo-server-address ip-address
- Specifies the list of IP addresses used.This option is supported if the option value type is IP, ASCII, or HEX. (Option 112.)
- nis-domain
- Specifies the NIS domain (entered as an ASCII character string) for the client. (Option 40.)
- nis-servers
- Specifies a list of IP addresses for NIS servers available to the client. Servers are listed in order of preference. (Option 41.)
- nisplus-domain
- Specifies the NIS+ domain (entered as an ASCII character string) for the client. (Option 64.)
- nisplus-servers
- Specifies a list of IP addresses for NIS+ servers available to the client. Servers are listed in order of preference. (Option 65.)
- nntp-server
- Specifies a list of Network News Transport Protocol (NNTP) Servers available to the client. Servers are listed in order of priority. (Option 71.)
- non-local-source-routing
- Specifies a flag to enable or disable non-local source route forwarding in the client. (Option 20.)
- ntp-servers
- Specifies a list of IP addresses for NTP servers available to the client. Servers are listed in order of preference. (Option 42.)
- path-mtu-aging-timeout
- Specifies the timeout (in seconds) to use when aging Path MTU values discovered. (Option 24.)
- path-mtu-plateau-table
- Specifies a table of MTU sizes to use when performing Path MTU Discovery. (Option 25.)
- perform-mask-discovery
- Specifies a table of MTU sizes to use when performing Path MTU Discovery. (Option 29.)
- policy-filter ip-address network mask
- Specifies Policy Filters for non-local source routing. The filters consist of a list of IP addresses and masks that specify destination/mask pairs with which to filter incoming source routes. Any source-routed datagram whose next-hop address does not match one of the filters should be discarded by the client. IP address pairs are accepted.(Option 21.)
- pop-server
- Specifies a list of Post Office Protocol (POP3) Servers available to the client. Servers are listed in order of priority. (Option 70.)
- pxe-interface-id
- Allows a client to specify its network interface type, major and minor revision. (Option 94.)
- pxe-system-type
- A list of one ore more 16-bit integers that allows a client to specify its pre-boot architecture type(s). (Option 93.)
- resource-location-servers
- Specifies a list of Resource Location Servers available to the client. Servers are listed in order of preference. (Option 11.)
- root-path
- Specifies the path name (entered as an ASCII character string) that contains the client root disk. (Option 17.)
- router-solicitation-address
- Specifies the address to which the client should transmit router solicitation requests. (Option 32.)
- routers
- Specifies an IP addresses of the default router on the client subnet. Only one router can be specified. (Option 3.)
- slp-directory-agent
- Specifies the IP addresses of SLP Directory Agents, and flags to set the use of these addresses. (Option 78.)
- slp-service-scope
- Specifies a list of service scopes for SLP, and whether the use of this list is mandatory. (Option 79.)
- smtp-server
- Specifies a list of Simple Mail Transport Protocol (SMTP) Servers available to the client. Servers are listed in order of priority. (Option 69.)
- static-routes destination ip-address static-route
- Specifies a list of Static Routes that the client should install in its routing cache. If multiple routes to the same destination are specified, they are listed in descending order of priority. The routes consist of a list of IP address pairs. The first address is the destination address, and the second address is the router for the destination. Note that the default route (0.0.0.0) is an illegal destination for a static route. (Option 33.)
- streettalk-server ip-address
- Specifies a list of StreetTalk Servers available to the client. Servers are listed in order of priority. (Option 75.)
- streettalk-directory-assistance-server ip-address
- Specifies a list of StreetTalk Directory Assistance (STDA) Servers available to the client. Servers are listed in order of priority. (Option 76.)
- subnet-mask
- Specifies the client subnet mask (per RFC 950). This is not configurable using the option command. This option is configured using the network (dhcp) command. (Option 1.)
- tcp-keepalive-garbage
- Specifies a flag to enable or disable TCP keepalive garbage in the client. (Option 39.)
- tcp-keepalive-interval
- Specifies the TCP keepalive interval timeout value used by the client. (Option 38.)
- tftp-server-name
- Specifies the address or name of the TFTP server available to the client. (Option 66.)
- time-servers
- Specifies a list of Time Servers available to the client. Time Servers are listed in order of preference. (Option 4.)
- trailer-encapsulation
- Specifies if the client uses trailers when using the ARP protocol. (Option 34.)
- uap-servers
- Specifies a list of URLs, each pointing to a user authentication service that is capable of processing authentication requests encapsulated in the User Authentication Protocol (UAP). (Option 98.)
- vendor-class-identifier string
- Specifies the Vendor Class Identifier. This is used in conjunction with option 43 (Vendor Specific information), allowing clients and servers to exchange vendor-specific information. (Option 60.)
- vendor-encapsulated-options { ascii string | hex value | ip ip-address }
- Specifies vendor-specific information. This allows clients and servers to exchange vendor-specific information. (Option 43.)
- vivso string
- Specifies Vendor-Identified vendor specific information. Only the string value is accepted. (Option 125.)
- www-server
- Specifies a list of World Wide Web (WWW) Servers available to the client. Servers are listed in order of priority. (Option 72.)
- ip
- Specifies the option-value is an IP address. You can configure up to a maximum of three IP addresses separated by a space.
DHCP server pool configuration mode
This command is used to specify DHCP options that the DHCP server passes to clients. For example, you can configure option 3, so the DHCP server passes the IP address of the default routers to the client.
Another example is option 43, allowing the DHCP server to pass vendor-specific information, in the form of a hex value, and IP address, or an ASCII string, to the clients that receive the DHCP ACK. With this example, configuring DHCP option 60 helps in identifying the incoming DHCP client. If the vendor class identifier (VCI) advertised by the DHCP client matches with the DHCP server, the server makes a decision to exchange the vendor-specific information configured as part of DHCP option 43.
The following option numbers must be configured
using the option number: 80 through 84, 90, 95, 96, 99 through 111, 115 through
117,
126 through 149, 151 through 255. The options 1 through 254 are allowed to be
configured using the option number. Options that have option names support are
automatically configured as option
option-name
option-value.
The following options accept the option value: 1 through 79, 85 through 89, 91 through 94, 97, 98, 112 through 114, 118, 119, 125, and 150.
Only one default router can be specified. Do not enter multiple router addresses.
The following example configures the boolean option ip-forwarding which specifies that the client should configure the IP layer for packet forwarding.
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option ip-forwarding 1
The following example configures option arp-cache-timeout which specifies the timeout in seconds for ARP cache entries. This option accepts integer values.
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option arp-cache-timeout 50
The following example configures a list of integers that specifies the MTU sizes to be used by clients when performing path MTU discovery.
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option path-mtu-plateau-table 512 1024
The following example specifies the service scope and flags to use the scope is mandatory or not.
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option slp-service-scope 0 slp1
The following example specifies the list of SLP agents and flags to use the agents to the clients.
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option slp-directory-agent 1 2.2.2.2 3.3.3.3
The following example specifies the static routes to be used by the clients.
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option static-routes 10.10.10.100 10.10.10.1
The following example specifies the policy filter to be used by the clients
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option policy-filter 10.10.10.50 255.255.255.0
The following example specifies the pxe-client-id type and client identity string.
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option pxe-client-id 1 pxe1
The following example configures
option
pxe-interface-id, which specifies the client's network
interface type, major version, and minor version.
device# configure terminal device(config)# ip dhcp-server pool 1 device(config-dhcp-1)# option pxe-interface-id 1 1 1