Find Technical Content
  • Home
  • Ruckus Support Portal
  • Ruckus Networks
  • Table of Contents
  • Dark Mode

Powered by Titania Delivery

⚠ This cached page may be outdated. Click refresh to get the latest content.
Cached Version You are Offline

You are viewing a cached version of this page.

You are currently offline. This page was loaded from cache.

RUCKUS FastIron MIB Reference, 10.0.10 53-1005776-08

  • 1 Vistance Legal Statements
  • Preface Ruckus
    • 3 Contact Information, Resources, and Conventions
      • 3.1 Contacting RUCKUS Customer Services and Support
      • 3.2 Document Feedback
      • 3.3 RUCKUS Product Documentation Resources
      • 3.4 Online Training Resources
      • 3.5 Document Conventions
      • 3.6 Command Syntax Conventions
  • 4 About This Document
    • 4.1 New in This Document
    • 4.2 Supported Hardware
  • Overview of the Unified IP MIB
    • 5 Overview
      • 5.1 Introduction
      • 5.2 Obtaining and installing the IP MIBs
        • 5.2.1 Downloading the MIB from the Ruckus Support website
        • 5.2.2 Downloading the MIB from the Ruckus FTP site
        • 5.2.3 Importing IP MIB into a UNIX environment
        • 5.2.4 Reloading MIBs into a third-party NMS
      • 5.3 Standard objects
      • 5.4 Proprietary objects
      • 5.5 SNMP support
  • 6 Supported Standard MIBs
    • 6.1 Supported on Brocade FastIron Devices
    • 6.2 RFC compliance - management
    • 6.3 LLDP MIB support
    • 6.4 LLDP\LLDP-MED MIB support
    • 6.5 RFC 1493: Definitions of Managed Objects for Bridges
    • 6.6 RFC 1757: Remote Network Monitoring Management Information Base
    • 6.7 RFC 1850: OSPF Version 2 Management Information Base
    • 6.8 RFC 2096: IP Forwarding Table MIB
    • 6.9 RFC 2787: Definitions of Managed Objects for the Virtual Router Redundancy Protocol
      • 6.9.1 VRRP operations table (vrrpOperTable)
      • 6.9.2 VRRP associated IP address table (vrrpAssoIpAddrTable)
      • 6.9.3 VRRP statistics (vrrpStatistics)
      • 6.9.4 VRRP router statistics (vrrpRouterStatsTable)
    • 6.10 RFC 2863: The Interfaces Group MIB
      • 6.10.1 ifIndex
        • 6.10.1.1 ifIndex assignment persistence
      • 6.10.2 ifType for interfaces
      • 6.10.3 Preserved SNMP statistics on interfaces
        • 6.10.3.1 IF-MIB (RFC 2863) ifTable objects
        • 6.10.3.2 IF-MIB (RFC 2863) ifXTable objects
        • 6.10.3.3 EthernetLike-MIB (RFC 3635) dot3StatsTable objects (Ethernet ports only)
        • 6.10.3.4 RMON-MIB (RFC 2819)
    • 6.11 RFC 2932: IPv4 Multicast Routing MIB
    • 6.12 RFC 2933: Internet Group Management Protocol MIB
    • 6.13 RFC 2934: Protocol Independent Multicast MIB for IPv4
    • 6.14 RFC 3411: SNMP Management Frameworks
    • 6.15 RFC 3418: Management Information Base (MIB) for the SNMP
    • 6.16 RFC 4087: IP Tunnel MIB
      • 6.16.1 tunnelIfTable
      • 6.16.2 tunnelInetConfigTable
    • 6.17 RFC 4133: Entity MIB (Version 3)
    • 6.18 RFC 4273: Definitions of Managed Objects for BGP-4
    • 6.19 draft-ietf-idr-bgp4-mibv2-12 MIB
      • 6.19.1 BGP4v2 per-peer session management information
      • 6.19.2 BGP4v2 per-peer error management information
      • 6.19.3 BGP4v2 per-peer event times table
      • 6.19.4 BGP4v2 NLRI table
    • 6.20 RFC 4292: Management Information Base for the IP Forwarding Table
    • 6.21 RFC 4293: Management Information Base for the Internet Protocol (IP)
    • 6.22 RFC 4836: MAU (Medium Attachment Unit) MIBs
      • 6.22.1 ifMauTable
      • 6.22.2 ifMauAutoNegTable
    • 6.23 RFC 5643: MIB for OSPF Version 3
      • 6.23.1 GeneralGroup
      • 6.23.2 AreaTable
      • 6.23.3 AS-Scope Link State Database
      • 6.23.4 Area-Scope Link State Database
      • 6.23.5 Link-Scope Link State Database
      • 6.23.6 Interface Table
      • 6.23.7 Virtual Interface Table
      • 6.23.8 Neighbor Table
      • 6.23.9 Virtual Neighbor Table
      • 6.23.10 Area Aggregate Table
      • 6.23.11 OSPFv3 Link-Scope Link State Database for Virtual Interfaces
      • 6.23.12 OSPFv3 Notifications
    • 6.24 RFC 5676: Definitions of Managed Objects for Mapping SYSLOG Messages to Simple Network Management Protocol (SNMP) Notifications
      • 6.24.1 SYSLOG objects
    • 6.25 LLDP-MIB
      • 6.25.1 lldpConfiguration
      • 6.25.2 lldpPortConfigTable
      • 6.25.3 lldpConfigManAddrTable
      • 6.25.4 lldpstatistics
      • 6.25.5 lldpStatsTxPortTable
      • 6.25.6 lldpStatsRxPortTable
      • 6.25.7 lldpLocalSystemData
      • 6.25.8 lldpLocPortTable
      • 6.25.9 lldpLocManAddrTable
      • 6.25.10 lldpRemTable
      • 6.25.11 lldpRemManAddrTable
      • 6.25.12 lldpRemUnknownTLVTable
      • 6.25.13 lldpRemOrgDefInfoTable
    • 6.26 LLDP-EXT-DOT1-MIB
      • 6.26.1 lldpXdot1ConfigPortVlanTable
      • 6.26.2 lldpXdot1ConfigVlanNameTable
      • 6.26.3 lldpXdot1ConfigProtoVlanTable
      • 6.26.4 lldpXdot1ConfigProtocolTable
      • 6.26.5 lldpXdot1LocTable
      • 6.26.6 lldpXdot1LocProtoVlanTable
      • 6.26.7 lldpXdot1LocVlanNameTable
      • 6.26.8 lldpXdot1LocProtocolTable
      • 6.26.9 lldpXdot1RemTable
      • 6.26.10 lldpXdot1RemProtoVlanTable
      • 6.26.11 lldpXdot1RemVlanNameTable
      • 6.26.12 lldpXdot1RemProtocolTable
    • 6.27 LLDP-EXT-DOT3-MIB
      • 6.27.1 lldpXdot3PortConfigTable
      • 6.27.2 lldpXdot3LocPortTable
      • 6.27.3 lldpXdot3LocPowerTable
      • 6.27.4 lldpXdot3LocLinkAggTable
      • 6.27.5 lldpXdot3LocMaxFrameSizeTable
      • 6.27.6 lldpXdot3RemPortTable
      • 6.27.7 lldpXdot3RemPowerTable
      • 6.27.8 lldpXdot3RemLinkAggTable
      • 6.27.9 lldpXdot3RemMaxFrameSizeTable
    • 6.28 RFC 4560 - Ping MIB
      • 6.28.1 Ping Table Global Objects MIB
      • 6.28.2 Ping Control Table MIB
      • 6.28.3 Ping Results Table
      • 6.28.4 Ping probe history table
    • 6.29 RFC 4560 - Traceroute MIB
      • 6.29.1 TraceRoute Table Global Objects MIB
      • 6.29.2 Traceroute Control Table Objects MIB
      • 6.29.3 Traceroute Result Table Objects MIB
      • 6.29.4 Traceroute Probe History Table Objects MIB
      • 6.29.5 Traceroute Hops Table Objects MIB
    • 6.30 Standard MIBs
  • 7 Registration MIB Definition
  • 8 Agent MIB Definition
    • 8.1 General chassis information
    • 8.2 Fan status
    • 8.3 Flash card
    • 8.4 Power supply table
    • 8.5 Stacking power supply table
    • 8.6 Fan table
    • 8.7 Stacking fan table
    • 8.8 Stacking chassis unit information
  • 9 Agent Groups
    • 9.1 Agent global group
    • 9.2 Image and configuration file download and upload
    • 9.3 Default gateway IP address
      • 9.4 Usage notes on CPU utilization and system CPU utility table
      • 9.5 Image version
      • 9.6 Agent board table
      • 9.7 Agent stacking board table
      • 9.8 Trap receiver table
      • 9.9 Boot sequence table
    • 10 Agent System Parameters
      • 10.1 Agent system parameters configuration table
      • 10.2 Configured module table
      • 10.3 Configuration module table for stacking
      • 10.4 Agent user access group
      • 10.5 Agent user account table
      • 10.6 System CPU utilization table
    • 11 Switch Group Configuration
      • 11.1 Switch group configuration
    • 12 Switch Port Information Group
      • 12.1 Switch port information
      • 12.2 Egress MIB counter table
    • 13 Interface ID Registration Group
      • 13.1 Interface ID to ifIndex lookup table
      • 13.2 ifIndex to interface ID lookup table
      • 13.3 Interface ID2 to ifIndex lookup table
      • 13.4 ifIndex to interface ID2 lookup table
      • 13.5 Optical lane monitoring table
    • 14 System DRAM
      • 14.1 System temperature table
      • 14.2 System stacking temperature table
      • 14.3 System stacking temperature threshold table
      • 14.4 Software licensing
    • DNS2 MIB Definition
      • 15 DNS MIB Definition
        • 15.1 DNS table
        • 15.2 DNS group (IPv4)
        • 15.3 IPv4 and IPv6 MIB table for DNS servers
    • 16 Trace route group
      • 16.1 Trace route group
      • 16.2 General trace route group
      • 16.3 Trace route result table
      • 16.4 IP prefix list table
      • 16.5 IP community list string table
    • 17 Power Over Ethernet MIB
      • 17.1 Power Over Ethernet global objects
      • 17.2 Power Over Ethernet port table
      • 17.3 POE unit table
    • 18 Stacking MIB Definition
      • 18.1 Global objects for stacking
      • 18.2 Stacking configuration unit table
      • 18.3 Stacking operation unit table
      • 18.4 Stacking neighbor port table
    • FDP MIB Defintions
      • 19 FDP MIB Definitions
        • 19.1 FDP interface table
        • 19.2 FDP cache table
        • 19.3 FDP global configuration objects
        • 19.4 FDP cached address entry table
    • 20 System Logging Group
      • 20.1 Global system logging group objects
      • 20.2 Dynamic system logging buffer table
      • 20.3 Static system logging buffer table
      • 20.4 System log server table
    • NetFlow and sFlow MIB
      • 21 sFlow MIB
        • 21.1 sFlow
          • 21.1.1 snSFlowGlb
          • 21.1.2 sFlow Collector Table
    • 22 VLAN Layer 2 Switch MIB Definition
      • 22.1 IEEE 802.1Q VLANs
      • 22.2 VLAN by port membership table
      • 22.3 Port VLAN configuration table
    • 23 Forwarding Database Group
      • 23.1 Forwarding database static table information
    • 24 Port STP Configuration Group
      • 24.1 Port STP configuration groups
        • 24.1.1 STP table
    • 25 MRP MIB Definition
      • 25.1 MRP table
    • 26 Trunk Port Configuration Group
      • 26.1 Switch configuration summary group
    • 27 RADIUS Group
      • 27.1 RADIUS general group
      • 27.2 RADIUS server table
    • 28 TACACS Group
      • 28.1 TACACS general MIBs
      • 28.2 TACACS server table
    • 29 Wired client visibility
      • 29.1 Wired Client Visibility
    • 30 Flexible Authentication MIB
      • 30.1 FlexAuth Global Configuration
      • 30.2 FlexAuth Dot1X configuration
      • 30.3 FlexAuth MAC Authentication Configuration
      • 30.4 FlexAuth Web Authentication Configuration
      • 30.5 Web Authentication DNS Filter Configuration
      • 30.6 Web Authentication Trusted Server or Whitelist Configuration
      • 30.7 Web Authentication Auth-Filter Configuration
      • 30.8 Web Authentication Captive Portal Configuration
      • 30.9 FlexAuth Port Configuration
      • 30.10 FlexAuth Port Auth-Filter Configuration
      • 30.11 FlexAuth Sessions
      • 30.12 FlexAuth Session Address Table
      • 30.13 FlexAuth MIB Conformance
    • 31 NDI MIB
      • 31.1 NDI VLAN Configuration Table
      • 31.2 NDI Interface Configuration Table
      • 31.3 NDI Entry Table
    • 32 DHCP Client List
      • 32.1 DHCP Client List
    • 33 Port MAC Security
      • 33.1 Port MAC security table
      • 33.2 Port MAC security module statistics table
      • 33.3 Port MAC security interface table
      • 33.4 Port MAC security interface MAC table
      • 33.5 Port MAC security autosave MAC table
      • 33.6 Port MAC security global MIB group
      • 33.7 Port monitor table
    • 34 MAC Authentication MIB Definition
      • 34.1 Multi-device port authentication
      • 34.2 MAC clear interface multi-device port authentication objects
      • 34.3 Multi-device port authentication objects
      • 34.4 Multi-device port authentication clear sessions
    • DHCP Snooping MIB Definition
      • 35 DHCP Snooping MIB Definition
        • 35.1 DHCP Snooping Global Scalar Object
        • 35.2 DHCP Snooping VLAN configuration table
        • 35.3 DHCP Snooping interface configuration table
        • 35.4 DHCP Snooping binding database table
      • 36 DHCPv6 Snooping MIB Definition
        • 36.1 DHCPv6 Snooping Global Scalar Object
        • 36.2 DHCPv6 Snooping VLAN Configuration Table
        • 36.3 DHCPv6 Snooping Interface Configuration Table
        • 36.4 DHCPv6 Snooping Binding Database Table
    • 37 IP Source Guard MIB Definition
      • 37.1 IP source guard interface configuration table
      • 37.2 IP source guard per port per VLAN configuration table
      • 37.3 IP source guard binding table
    • 38 DAI MIB Definition
      • 38.1 DAI VLAN configuration table
      • 38.2 DAI interface configuration table
      • 38.3 DAI entry table
    • RUCKUS-ACL-MIB
      • 39 RUCKUS-ACL-MIB
        • 39.1 RUCKUS-ACL-MIB Table
      • 40 RUCKUS-VXLAN-MIB
        • 40.1 RUCKUS-VXLAN-MIB Table
    • 41 IP VRRP MIB Definition
      • 41.1 VRRP and VRRP-Extended MIBs
      • 41.2 VRRP interface table
      • 41.3 VRRP and VRRP-E interface table
      • 41.4 VRRP and VRRP-E virtual router configuration table
    • 42 VSRP MIB Definition
      • 42.1 Global VSRP objects
      • 42.2 VSRP interface table
      • 42.3 VSRP virtual router table
    • 43 IP MIB Definition
      • 43.1 IP general group
      • 43.2 IP static route table
      • 43.3 Static Routes
      • 43.4 IP-Forward-MIB
      • 43.5 IP filter table
    • 44 IPv6 MIB Definition
      • 44.1 ECMP MIB objects
    • 45 BGP4 MIB Definition
      • 45.1 BGP4 general variables
      • 45.2 BGP4 neighbor summary table
    • 46 Broadcast Forwarding Group
      • 46.1 IP Helper Address Table
    • 47 Router IP MIB Definition
      • 47.1 IP RIP general group
      • 47.2 IP RIP redistribution table
    • 48 IPSec MIB Definition
      • 48.1 Counters support for IPSec
      • 48.2 IPsec endpoint to group table
      • 48.3 IPsec global system policy group table
      • 48.4 IPsec filter table
      • 48.5 spdStaticActions Table
      • 48.6 spdStaticFiltersTable
    • Brocade Entity OID MIB Definition
      • 49 Entity OID MIB Definition
        • 49.1 Entity MIBs
    • 50 QoS Profile Group
      • 50.1 QoS profile table
      • 50.2 QoS bind table
      • 50.3 DOS attack statistics
      • 50.4 Authentication, Authorization, and Accounting
      • 50.5 DSCP QoS Profile Table
    • 51 CAR MIB Definition
      • 51.1 CAR port table
      • 51.2 VLAN CAR objects
    • 52 LAG MIB Definition
      • 52.1 LAG group table
      • 52.2 LAG LACP Port Table
    • 53 Switch Port Extender MIB Definition
      • 53.1 SPX global scalar MIB objects
      • 53.2 SPX configuration unit table
      • 53.3 SPX operation unit table
      • 53.4 SPX configuration CB SPX port table
      • 53.5 SPX configuration CB SPX LAG table
      • 53.6 SPX PE group table
    • ISSU MIB Definitions
      • 54 ISSU MIB Definition
        • 54.1 Stack ISSU Global Scalar Objects
        • 54.2 Stack ISSU status unit table
        • 54.3 Stack ISSU SNMP traps
    • 55 DHCPv4 Server Global Objects
    • 56 DHCPv4 Server Pool Config Table
    • 57 DHCPv4 Server Pool Option Table
    • 58 DHCPv4 Server Pool Excluded Address Tables
    • 59 DHCPv6 Server MIB Definition
      • 59.1 DHCPv6 Server Global Scalar Objects
      • 59.2 DHCPv6 Server Subnet Configuration Table
      • 59.3 Static Routes
    • 60 Trap MIB Definition
      • 60.1 Objects to enable or disable standard traps
      • 60.2 Standard traps
        • 60.2.1 System status traps
        • 60.2.2 Traps for STP
        • 60.2.3 Traps for alarms
        • 60.2.4 Ping notifications
      • 60.3 Proprietary traps
        • 60.3.1 General traps
        • 60.3.2 MAC-based VLAN traps
        • 60.3.3 Cloud management traps
        • 60.3.4 VRRP traps
        • 60.3.5 VRRPE Traps
        • 60.3.6 VSRP traps
        • 60.3.7 OSPF traps
        • 60.3.8 DHCP Traps
        • 60.3.11 Port security traps
        • 60.3.12 MRP traps
        • 60.3.13 BPDU guard and root guard traps
        • 60.3.14 Traps for stacking
          • 60.3.14.1 Other traps
        • 60.3.15 LAG LACP MAC notification
        • 60.3.17 Software licensing traps

    Vistance Legal Statements

    ©2026 Vistance Networks, Inc. All rights reserved.

    No part of this content may be reproduced in any form or by any means or used to make any derivative work (such as translation, transformation, or adaptation) without written permission from Vistance Networks, Inc. and/or its affiliates (“Vistance”). Vistance reserves the right to revise or change this content from time to time without obligation on the part of Vistance to provide notification of such revision or change.

    Export Restrictions

    These products and associated technical data (in print or electronic form) may be subject to export control laws of the United States of America. It is your responsibility to determine the applicable regulations and to comply with them. The following notice is applicable for all products or technology subject to export control:

    These items are controlled by the U.S. Government and authorized for export only to the country of ultimate destination for use by the ultimate consignee or end-user(s) herein identified. They may not be resold, transferred, or otherwise disposed of, to any other country or to any person other than the authorized ultimate consignee or end-user(s), either in their original form or after being incorporated into other items, without first obtaining approval from the U.S. government or as otherwise authorized by U.S. law and regulations.  

    Disclaimer

    THIS CONTENT AND ASSOCIATED PRODUCTS OR SERVICES ("MATERIALS"), ARE PROVIDED "AS IS" AND WITHOUT WARRANTIES OF ANY KIND, WHETHER EXPRESS OR IMPLIED. TO THE FULLEST EXTENT PERMISSIBLE PURSUANT TO APPLICABLE LAW, VISTANCE DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, TITLE, NON-INFRINGEMENT, FREEDOM FROM COMPUTER VIRUS, AND WARRANTIES ARISING FROM COURSE OF DEALING OR COURSE OF PERFORMANCE. Vistance does not represent or warrant that the functions described or contained in the Materials will be uninterrupted or error-free, that defects will be corrected, or are free of viruses or other harmful components. Vistance does not make any warranties or representations regarding the use of the Materials in terms of their completeness, correctness, accuracy, adequacy, usefulness, timeliness, reliability or otherwise. As a condition of your use of the Materials, you warrant to Vistance that you will not make use thereof for any purpose that is unlawful or prohibited by their associated terms of use.

    Limitation of Liability

    IN NO EVENT SHALL VISTANCE, VISTANCE AFFILIATES, OR THEIR OFFICERS, DIRECTORS, EMPLOYEES, AGENTS, SUPPLIERS, LICENSORS AND THIRD PARTY PARTNERS, BE LIABLE FOR ANY DIRECT, INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL, EXEMPLARY OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER, EVEN IF VISTANCE HAS BEEN PREVIOUSLY ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, WHETHER IN AN ACTION UNDER CONTRACT, TORT, OR ANY OTHER THEORY ARISING FROM YOUR ACCESS TO, OR USE OF, THE MATERIALS. Because some jurisdictions do not allow limitations on how long an implied warranty lasts, or the exclusion or limitation of liability for consequential or incidental damages, some of the above limitations may not apply to you.

    Trademarks

    Vistance Networks, Aurora Networks, and RUCKUS Networks and their associated logos are trademarks of Vistance Networks, Inc. and/or its affiliates in the U.S. and other countries. For additional trademark information see https://www.vistancenetworks.com/trademarks/. All product names, trademarks and registered trademarks are property of their respective owners.

    Patent Marking Notice

    For applicable patents, see:

    • www.an-pat.com (Aurora Networks)
    • www.RN-pat.com (RUCKUS Networks)

    Did you find what you were looking for?

    Thanks!

    Ruckus Wireless

    © 2026 Ruckus Wireless LLC All rights reserved.

    • Accessibility
    • Privacy & Cookies
    • Do Not Sell My Information
    • Trademarks
    • Terms
    • Feedback