BGP4 general variables

The BGP4 implementation complies with RFC 4273. The BGP4 implementation also supports the following RFCs:

  • RFC 1745 (OSPF Interactions)
  • RFC 1965 (BGP4 Confederations)
  • RFC 1997 (BGP Communities Attributes)
  • RFC 2385 (TCP MD5 Signature Option)
  • RFC 2439 (Route Flap Dampening)
  • RFC 2796 (Route Reflection)
  • RFC 2842 (Capability Advertisement)

The BGP4 objects apply globally to a device’s BGP4 process.

Name, OID, and syntax

Access

Description

snBgp4Gen

brcdIp.1.2.11.1

Syntax: Integer

None

snBgp4GenAdminStat

brcdIp.1.2.11.1.13

Read-write The administrative status of BGP4 in the router. The value 'enabled' denotes that the BGP4 routing is active in this router; and 'disabled' disables BGP4 routing on this router.
  • disabled(0)
  • enabled(1)
snBgp4GenLocalAs

brcdIp.1.2.11.1.28

Syntax: Integer

Read-write BGP4 local autonomous system number.