Implementation of BGP4

BGP4 is described in RFC 1771 and the latest BGP4 drafts. The RUCKUS BGP4 implementation fully complies with RFC 1771. RUCKUS BGP4 implementation also supports the following RFCs:

  • RFC 1745 (OSPF Interactions)
  • RFC 1997 (BGP Communities Attributes)
  • RFC 2385 (TCP MD5 Signature Option)
  • RFC 2439 (Route Flap Dampening)
  • RFC 2796 (Route Reflection)
  • RFC 2842 (Capability Advertisement)
  • RFC 3065 (BGP4 Confederations)
  • RFC 2858 (Multiprotocol Extensions)
  • RFC 2918 (Route Refresh Capability)
  • RFC 3392 (BGP4 Capability Advertisement)
  • RFC 4893 BGP Support for Four-octet AS Number Space
  • RFC 3682 Generalized TTL Security Mechanism, for eBGP Session Protection