DHCP server options

A FastIron device configured as a DHCP server can support up to 500 DHCP clients.

Where a FastIron device is configured as a DHCP server, you can configure DHCP options. These options are passed to the connected DHCP clients and allow configuration of parameters such as default router, host name, and domain name server.

The list of supported DHCP options is shown in the following table:

DHCP server options

Option Number Option Name Description / Notes
1 Subnet Mask Specifies the client subnet mask (per RFC 950). This is not configurable using the option command. This option is configured using the network (dhcp) command.

Network <router IP> <subnet mask>

3 Router Option Specifies an IP addresses of the default router on the client subnet. Only one router can be specified.
Note: Option 3 is not supported on non-default VRFs and management VRFs.
Note: Option 3 functions only when there is no previously configured route on the DHCP client. If the route received by the DHCP client from the DHCP server is already configured on the client, the following syslog message is displayed: DHCP: Failed to configure default gateway.
4 Time Server Specifies a list of Time Servers available to the client. Time Servers are listed in order of preference.
5 Name Server Specifies a list of Name Servers available to the client. Name Servers are listed in order of preference.
6 Domain Name Server Specifies a list of Domain Name System (RFC 1035) name servers available to the client. Servers are listed in order of preference.
7 Log Server Specifies a list of UDP log servers available to the client. Servers are listed in order of preference.
8 Quotes Server Specifies a list of Quotes servers available to the client. Servers are listed in order of preference.
9 LPR Server Specifies a list of Line Printer Servers available to the client. Servers are listed in order of preference.
10 Impress Server Specifies a list of Imagen Impress Servers available to the client. Servers are listed in order of preference.
11 RLP Server Specifies a list of Resource Location Servers available to the client. Servers are listed in order of preference.
12 Hostname Configures the host name that can be assigned to the DHCP clients.
15 Domain name Specifies the domain name the client should use when resolving host names using the Domain Name System.
16 Swap Server Specifies the IP address of the client Swap Server.
17 Root Path Specifies the path name (entered as an ASCII character string) that contains the client root disk.
18 Extension File Specifies a file, retrievable through TFTP, that contains information that can be interpreted in the same way as the vendor-extension field within the BOOTP response, with the following exceptions:
  • the length of the file is unconstrained
  • all references to instances of this option in the file are ignored
21 Policy Filter Specifies Policy Filters for non-local source routing. The filters consist of a list of IP addresses and masks that specify destination/mask pairs with which to filter incoming source routes. Any source-routed datagram whose next-hop address does not match one of the filters should be discarded by the client.
28 Broadcast Address Specifies the Broadcast Address in use on the client subnet.
32 Router Request Specifies the address to which the client should transmit router solicitation requests.
33 Static Route Specifies a list of Static Routes that the client should install in its routing cache. If multiple routes to the same destination are specified, they are listed in descending order of priority. The routes consist of a list of IP address pairs. The first address is the destination address, and the second address is the router for the destination. Note that the default route (0.0.0.0) is an illegal destination for a static route.
40 NIS Domain Specifies the NIS domain (entered as an ASCII character string) for the client.
41 NIS Servers Specifies a list of IP addresses for NIS servers available to the client. Servers are listed in order of preference.
42 NTP Servers Specifies a list of IP addresses for NTP servers available to the client. Servers are listed in order of preference.
43 Vendor Specific Specifies vendor-specific information. This allows clients and servers to exchange vendor-specific information. The vendor is specified in the Vendor Class Identifier option (option 60).
44 NetBIOS Name Srv Specifies a list of NetBIOS Name Servers (NBNS) (RFC 1001 and RFC 1002). NBNS servers are listed in order of preference.
45 NetBIOS Dist Srv Specifies a list of NetBIOS Datagram Distribution Servers (NBDD) servers (RFC 1001 and RFC 1002). NBDD servers are listed in order of preference.
47 NetBIOS Scope Specifies the NetBIOS over TCP/IP scope parameter (RFC 1001 and RFC 1002) for the client.
48 X Window Font Specifies a list of IP addresses of X Window System Font servers available to the client. X Window System Font servers are listed in order of preference.
49 X Window Manager Specifies a list of IP addresses of X Window System Display Managers available to the client. X Window System Display Managers are listed in order of preference.
50 Address Request Specifies an IP address used in a client request (DHCPDISCOVER) to allow the client to request a particular IP address be assigned.
56 DHCP Message This option is used by a DHCP server to provide an error message to a DHCP client in a DHCPNAK message in the event of a failure. A client may use this option in a DHCPDECLINE message to indicate the why the client declined the offered parameters. The message consists ASCII text, which the client may display on an available output device.
60 Vendor Class Identifier Specifies the Vendor Class Identifier. This is used in conjunction with option 43 (Vendor Specific information), allowing clients and servers to exchange vendor-specific information.
62 NetWare/IP Domain Specifies the NetWare/IP Domain Name used by the NetWare/IP product.
64 NIS-Domain-Name Specifies the NIS+ domain (entered as an ASCII character string) for the client.
65 NIS-Server-Addr Specifies a list of IP addresses for NIS+ servers available to the client. Servers are listed in order of preference.
66 TFTP server hostname or IP address Specifies the address or name of the TFTP server available to the client.
67 Boot File name Specifies a boot image to be used by the client.
68 Home-Agent-Addrs Specifies a list of IP addresses for Mobile IP Home Agents available to the client. Agents are listed in order of priority.
69 SMTP-Server Specifies a list of Simple Mail Transport Protocol (SMTP) Servers available to the client. Servers are listed in order of priority.
70 POP3-Server Specifies a list of Post Office Protocol (POP3) Servers available to the client. Servers are listed in order of priority.
71 NNTP-Server Specifies a list ofNetwork News Transport Protocol (NNTP) Servers available to the client. Servers are listed in order of priority.
72 WWW-Server Specifies a list of World Wide Web (WWW) Servers available to the client. Servers are listed in order of priority.
73 Finger-Server Specifies a list of Finger Servers available to the client. Servers are listed in order of priority.
74 IRC-Server Specifies a list of Internet Relay Chat (IRC) Servers available to the client. Servers are listed in order of priority.
75 StreetTalk-Server Specifies a list of StreetTalk Servers available to the client. Servers are listed in order of priority.
76 STDA-Server Specifies a list of StreetTalk Directory Assistance (STDA)Servers available to the client. Servers are listed in order of priority.
82 DHCP Relay Agent Information Option nables a DHCP relay agent to include information about itself when forwarding client-originated DHCP packets to a DHCP server. The DHCP server uses this information to implement IP address assignments or other parameter-assignment policies. Note that this option cannot be configured using the option command but is configured using the ip dhcp-server relay-agent-echo enable command.
85 NDS Servers Specifies the IP addresses for Novell Directory Services (NDS) servers available to the client. Servers are listed in order of priority.
86 NDS Tree Name Specifies the name of the Novell Directory Services (NDS) Tree to which the client will connect.
88 BCMCS Domain List Specifies a list of Broadcast and Multicast Service (BCMCS) Controller domains.
89 BCMCS IPv4 addr Specifies a list of IP addresses for Broadcast and Multicast Service (BCMCS) controllers. Controllers are listed in order of priority.
94 Client NDI Specifies the Network Interface Identifier (NDI) for the client.
95 LDAP This option is supported if the option value type is IP, ASCII, or HEX
98 User-Auth Specifies a list of URLs, each pointing to a user authentication service that is capable of processing authentication requests encapsulated in the User Authentication Protocol (UAP).

If a URL does not contain a port component, the normal default port is assumed (port 80 for http and port 443 for https)

If a URL does not include a path component, the path /uap is assumed.

100 Pcode Specifies the TZ-POSIX string used to provide timezone details.
101 Tcode Specifies the TZ-Database string used to provide timezone details.
102 - 111 Removed/Unassigned These options are supported if the value type is defined as IP, ASCII, or HEX
112 Netinfo Address This option is supported if the option value type is IP, ASCII, or HEX
113 Netinfo Tag This option is supported if the option value type is IP, ASCII, or HEX
114 URL This option is supported if the option value type is IP, ASCII, or HEX
120 SIP Servers Specifies the IP address or, preferably, the DNS fully qualified domain name to be used by the Session Initiation Protocol (SIP) client to locate a SIP server.
125 V-I VendorSpeciInfo This option is supported if the value type is defined as IP, ASCII, or HEX This option is supported if the value type is defined as IP, ASCII, or HEX
126 - 127 Removed/Unassigned These options are supported if the option value type is IP, ASCII, or HEX
128 - 135 PXE-VendorSpecific These options are supported if the option value type is IP, ASCII, or HEX
137 V4_LOST Specifies the fully qualified domain name (FQDN) to be used by the client to locate a Location-to-Service Translation (LoST) server.
141 SIP UA Domains Specifies a list of domain names to search for Session Initiation Protocol (SIP) User Agent Configuration.
142 IPv4-ANDSF Specifies the IP addresses for Access Network Discover and Selection Function (ANDSF) Servers available to the client. The servers are listed in order of priority.
146 RDNSS Selection This option is supported if the option value type is IP, ASCII, or HEX
147 - 148 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
150 TFTP Server Addr Specifies the address of the TFTP Server available to the client. Note that only one TFTP server IP address can be defined.
156 dhcp-state This option is supported if the option value type is IP, ASCII, or HEX
160 Captive-Portal This option is supported if the option value type is IP, ASCII, or HEX
161 - 174 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
175 Etherboot This option is supported if the option value type is IP, ASCII, or HEX
176 IP Tele-VoiceSrvr Configures the IP telephone voice parameters for Avaya IP phones running as DHCP clients.
177 PktCable-CableHome This option is supported if the option value type is IP, ASCII, or HEX
178 - 206 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
209 Config File Specifies the configuration file to be used in a PXELINUX environment.
210 Path Prefix Specifies a path prefix for the configuration file used in a PXELINUX environment.
213 V4_ACCESS_DOMAIN Specifies the access network domain name available to the client for the purposes of discovering a Local Information Server (LIS).
214 - 218 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
221 VSS This option is supported if the option value type is IP, ASCII, or HEX
222 - 223 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
224 - 241 Reserved These options are supported if the option value type is IP, ASCII, or HEX
242 IP Tele-DataSrvr Configures the IP telephone data parameters for Avaya IP phones running as DHCP clients.
243 - 251 Reserved These options are supported if the option value type is P, ASCII, or HEX
252 WPAD Configures the Proxy-Auto Config (PAC) file location string for the Web Proxy Auto-Discovery (WPAD) supported DHCP clients.
253 - 254 Reserved These options are supported if the option value type is IP, ASCII, or HEX
Note: Options not listed in the table are not supported or not configurable using the option command.

A DHCP server assigns and manages IPv4 addresses from multiple address pools, using dynamic address allocation. The DHCP server also contains the relay agent to forward DHCP broadcast messages to network segments that do not support these types of messages.

Recommendations and limitations

The list of supported DHCP options is extensive. However, the number of options that can be passed to the client is limited by the size of the ACK packet. It is recommended that you configure essential options only for the specific DHCP server address pool.

The following options (if configured) are prioritized, with additional options added as needed:

  • 3 - Router Option
  • 6 - Domain Name Server
  • 12 - Hostname
  • 15 - Domain name
  • 66 - TFTP server hostname or IP address
  • 67 - Boot file name
  • 60 - Vendor-Specific Information

DHCP options are not validated by the DHCP server. You must ensure the values are configured correctly.

Upgrade considerations

In FastIron 08.0.61 or earlier releases, it was possible to configure a subset of these DHCP options using specific commands. For example, dhcp-default-router allows configuration of the DHCP default router (which is now also configurable using DHCP option 3). When upgrading to FastIron 08.0.70 or later releases, any configured DHCP options are retained. However, the configuration is stored and shown in the new options format. The following table shows the options available in earlier releases and a mapping between the current option format and the corresponding commands available in earlier releases.

Option Command Mappings between Current Formats and Previous Releases

Option Number and Name Command in Release 08.0.70 and Later Command in Release 08.0.61 and Earlier
1 - Subnet Mask networkrouter-IPsubnet mask

Note that this essential option is configured using the network command. It is not configurable using the option command.

networkrouter-IPsubnet mask
3 - Router Option option 3 iprouter -IP dhcp-default-router router -IP
6 - Domain Name Server option 6 ip server-IP-address dns-server server-IP-address
12 - Hostname option 12 ascii hostname host-namehostname
15 - Domain name option 15 asciidomain-name domain-nameascii-string-domain-name
47 - NetBIOS over TCP/IP Name Server option 47 ipServer-IP netbios-name-server Server-IP
49 - X Window System Display Manager option 49 ipXWindow-manager-IP xwindow-managerXWindow-manager-IP
66 - TFTP server hostname option 66 asciiTFTP-server-hostname tftp-serverTFTP-server-hostname
67 - Bootfile name option 67 ascii bootfile-name bootfilebootfile-name
150 - TFTP server IP address option 150 ipTFTP-server-IP tftp-serverTFTP-server-IP
176 - ip-telephony voice server option 176 mcipadd mcport,… ip-telephony voice mcipadd mcport,…
242 - ip-telephony data server option 242 mcipadd mcport,… ip-telephony data mcipadd mcport,…
252 - Proxy-Auto Config (PAC) option 252 asciiURL-to-config-file wpad URL-to-config-file
60 - Vendor-Specific Information option 60 asciiVCI vendor-classascii-string-VCI

Note that the existing commands are still supported. However, it is recommended that you configure these using the option command where appropriate. The configuration is stored and shown in the options format, irrespective of whether the option is configured using the option command or the commands available in previous releases.