DHCP Server Options

A FastIron device configured as a DHCP server can support up to 3000 DHCP clients.

Where a FastIron device is configured as a DHCP server, you can configure DHCP options. These options are passed to the connected DHCP clients and allow configuration of parameters such as default router, host name, and domain name server.

The list of supported DHCP options that are configured using option number is shown in the following table:

The following option numbers must be configured using the option number: 80 through 84, 90, 95, 96, 99 through 111, 115 through 117, 126 through 149, 151 through 255. The options 1 through 254 are allowed to be configured using the option number. Options that have option names support are automatically configured as option option-name option-value.

DHCP Server Options

Option Option Number Option Name Description / Notes
subnet-mask 1 Subnet Mask Specifies the client subnet mask (per RFC 950). This is not configurable using the option command. This option is configured using the network (dhcp) command.

Network <router IP> <subnet mask>

time-offset 2 Time offset Specifies the offset of the subnet of the client in seconds from UTC.
routers 3 Router Option Specifies an IP addresses of the default router on the client subnet. Only one router can be specified.
Note: Option 3 is not supported on non-default VRFs and management VRFs.
Note: Option 3 functions only when there is no previously configured route on the DHCP client. If the route received by the DHCP client from the DHCP server is already configured on the client, the following syslog message is displayed: DHCP: Failed to configure default gateway.
time-servers 4 Time Server Specifies a list of Time Servers available to the client. Time Servers are listed in order of preference.
ien116-name-servers 5 Name Server Specifies a list of Name Servers available to the client. Name Servers are listed in order of preference.
domain-name-servers 6 Domain Name Server Specifies a list of Domain Name System (RFC 1035) name servers available to the client. Servers are listed in order of preference.
log-servers 7 Log Server Specifies a list of UDP log servers available to the client. Servers are listed in order of preference.
cookie-servers 8 Cookie Server Specifies the list of RFC 865 cookie servers available to the client. Servers are listed in order of preference.
lpr-servers 9 LPR Server Specifies a list of Line Printer Servers available to the client. Servers are listed in order of preference.
impress-servers 10 Impress Server Specifies a list of Imagen Impress Servers available to the client. Servers are listed in order of preference.
resource-location-servers 11 RLP Server Specifies a list of Resource Location Servers available to the client. Servers are listed in order of preference.
host-name 12 Hostname Configures the host name that can be assigned to the DHCP clients.
boot-size 13 Boot size Specifies the length of the default boot image for the client in 512-octet blocks.
merit-dump 14 Merit dump Specifies the path name of the core file of the client when the client crashes.
domain-name 15 Domain name Specifies the domain name the client should use when resolving host names using the Domain Name System.
swap-server 16 Swap Server Specifies the IP address of the client Swap Server.
root-path 17 Root Path Specifies the path name (entered as an ASCII character string) that contains the client root disk.
extensions-path 18 Extension Path Specifies a file, retrievable through TFTP, that contains information that can be interpreted in the same way as the vendor-extension field within the BOOTP.
ip-forwarding 19 IP forwarding Specifies if the client should configure its IP layer for packet forwarding.
non-local-source-routing 20 Non-local source routing Specifies a flag to enable or disable non-local source route forwarding in the client.
policy-filter ip-address network mask 21 Policy Filter Specifies Policy Filters for non-local source routing. The filters consist of a list of IP addresses and masks that specify destination/mask pairs with which to filter incoming source routes. Any source-routed datagram whose next-hop address does not match one of the filters should be discarded by the client.
max-dgram-reassembly 22 Maximum datagram reassembly Specifies the maximum size datagram that the client can reassemble.
default-ip-ttl 23 Default IP TTL Specifies the default time-to-live that the client should use on outgoing datagrams.
path-mtu-aging-timeout 24 Path MTU aging timeout Specifies the timeout (in seconds) to use when aging Path MTU values discovered.
path-mtu-plateau-table 25 Path MTU plateau table Specifies a table of MTU sizes to use when performing Path MTU Discovery.
interface-mtu 26 Interface MTU Specifies the MTU to use for the interface.
all-subnets-local 27 All subnets local Specifies that all connected subnets use the same MTU.
broadcast-address 28 Broadcast Address Specifies the Broadcast Address in use on the client subnet.
perform-mask-discovery 29 Perform mask discovery Specifies a table of MTU sizes to use when performing Path MTU Discovery.
mask-supplier 30 Mask Supplier Specifies if the client responds to subnet mask requests using ICMP.
router-discovery 31 Router Discovery Specifies if the client should perform Router Discovery.
router-solicitation-address 32 Router Request Specifies the address to which the client should transmit router solicitation requests.
static-routes destination ip-address static-route 33 Static Route Specifies a list of Static Routes that the client should install in its routing cache. If multiple routes to the same destination are specified, they are listed in descending order of priority. The routes consist of a list of IP address pairs. The first address is the destination address, and the second address is the router for the destination. Note that the default route (0.0.0.0) is an illegal destination for a static route.
trailer-encapsulation 34 Trailer encapsulation Specifies if the client uses trailers when using the ARP protocol.
arp-cache-timeout 35 ARP cache timeout Specifies the timeout in seconds for ARP cache entries.
ieee802-3-encapsulation 36 IEEE 802-3 encapsulation Specifies if the client should use Ethernet Version 2 (RFC 894) or IEEE 802.
default-tcp-ttl 37 Default TCP TTL Specifies the default TTL that the client should use when sending TCP segments.
tcp-keepalive-interval 38 TCP keepalive interval Specifies the TCP keepalive interval timeout value used by the client.
tcp-keepalive-garbage 39 TCP keepalive garbage Specifies a flag to enable or disable TCP keepalive garbage in the client.
nis-domain 40 NIS Domain Specifies the NIS domain (entered as an ASCII character string) for the client.
nis-servers 41 NIS Servers Specifies a list of IP addresses for NIS servers available to the client. Servers are listed in order of preference.
ntp-servers 42 NTP Servers Specifies a list of IP addresses for NTP servers available to the client. Servers are listed in order of preference.
vendor-encapsulated-options { ascii string | hex string | ip { address | address-list} } 43 Vendor Specific Specifies vendor-specific information. This allows clients and servers to exchange vendor-specific information. The vendor is specified in the Vendor Class Identifier option (option 60).
netbios-name-servers 44 NetBIOS Name Srv Specifies a list of NetBIOS Name Servers (NBNS) (RFC 1001 and RFC 1002). NBNS servers are listed in order of preference.
netbios-dd-server 45 NetBIOS Dist Srv Specifies a list of NetBIOS Datagram Distribution Servers (NBDD) servers (RFC 1001 and RFC 1002). NBDD servers are listed in order of preference.
netbios-node-type 46 NetBios Node Type Specifies the NetBIOS node type option.
netbios-scope 47 NetBIOS Scope Specifies the NetBIOS over TCP/IP scope parameter (RFC 1001 and RFC 1002) for the client.
font-servers 48 X Window Font Specifies a list of IP addresses of X Window System Font servers available to the client. X Window System Font servers are listed in order of preference.
x-display-manager 49 X Window Manager Specifies a list of IP addresses of X Window System Display Managers available to the client. X Window System Display Managers are listed in order of preference.
dhcp-requested-address 50 Address Request Specifies an IP address used in a client request (DHCPDISCOVER) to allow the client to request a particular IP address be assigned.
dhcp-lease-time 51 DHCP Lease Time Specifies the DHCP lease time.
dhcp-option-overload 52 DHCP Option Overload Indicates the DHCP 'sname' or 'file' fields are overloaded by using them to carry DHCP options
dhcp-message-type 53 DHCP Message Type Specifies the type of DHCP message contained in the DHCP packet.
dhcp-server-identifier 54 DHCP Server Identifier Specifies the IP address of the server.
dhcp-parameter-request-list list-of-integers 55 DHCP Parameter Request List Specifies the options to be sent to the client.
dhcp-message 56 DHCP Message This option is used by a DHCP server to provide an error message to a DHCP client in a DHCPNAK message in the event of a failure.
dhcp-max-message-size 57 DHCP Maximum Message Size DHCP maximum message size. Used as default, if not provided by the client.
dhcp-renewal-time 58 DHCP Renewal Time Specifies the renewal time in the DHCP client.
dhcp-rebinding-time 59 DHCP Rebinding Time Specifies the rebinding time in the DHCP client.
vendor-class-identifier string 60 Vendor Class Identifier Specifies the Vendor Class Identifier. This is used in conjunction with option 43 (Vendor Specific information), allowing clients and servers to exchange vendor-specific information.
dhcp-client-identifier 61 DHCP Client Identifier Specifies the DHCP client identifier.
nwip-domain 62 NetWare/IP Domain Specifies the NetWare/IP Domain Name used by the NetWare/IP product.
nwip-suboptions 63 NetWare sub-options Specifies a sequence of suboptions for NetWare/IP clients (RFC2242).
nisplus-domain 64 NIS-Domain-Name Specifies the NIS+ domain (entered as an ASCII character string) for the client.
nisplus-servers 65 NIS-Server-Addr Specifies a list of IP addresses for NIS+ servers available to the client. Servers are listed in order of preference.
tftp-server-name 66 TFTP server hostname or IP address Specifies the address or name of the TFTP server available to the client.
bootfile-name 67 Boot File name Specifies a boot image to be used by the client.
mobile-ip-home-agent 68 Home-Agent-Addrs Specifies a list of IP addresses for Mobile IP Home Agents available to the client. Agents are listed in order of priority.
smtp-server 69 SMTP-Server Specifies a list of Simple Mail Transport Protocol (SMTP) Servers available to the client. Servers are listed in order of priority.
pop-server 70 POP3-Server Specifies a list of Post Office Protocol (POP3) Servers available to the client. Servers are listed in order of priority.
nntp-server 71 NNTP-Server Specifies a list of Network News Transport Protocol (NNTP) Servers available to the client. Servers are listed in order of priority.
www-server 72 WWW-Server Specifies a list of World Wide Web (WWW) Servers available to the client. Servers are listed in order of priority.
finger-server 73 Finger-Server Specifies a list of Finger Servers available to the client. Servers are listed in order of preference.
irc-server 74 IRC-Server Specifies a list of Internet Relay Chat (IRC) Servers available to the client. Servers are listed in order of priority.
streettalk-server ip-address 75 StreetTalk-Server Specifies a list of StreetTalk Servers available to the client. Servers are listed in order of priority.
streettalk-directory-assistance-server ip-address 76 STDA-Server Specifies a list of StreetTalk Directory Assistance (STDA)Servers available to the client. Servers are listed in order of priority.
user-class 77 User Class Specifies identifying information to the DHCP client.
slp-directory-agent 78 SLP Directory Agent Specifies the IP addresses of SLP Directory Agents, and flags to set the use of these addresses.
slp-service-scope 79 SLP Service Scope Specifies a list of service scopes for SLP, and whether the use of this list is mandatory.
nds-servers 85 NDS Servers Specifies the IP addresses for Novell Directory Services (NDS) servers available to the client. Servers are listed in order of priority.
nds-tree-name string 86 NDS Tree Name Specifies the name of the Novell Directory Services (NDS) Tree to which the client will connect.
nds-context 87 NDS Context Specifies the name of the initial Netware Directory Service for an NDS client.
bcms-controller-names 88 BCMCS Domain List Specifies a list of Broadcast and Multicast Service (BCMCS) Controller domain names.
bcms-controller-address 89 BCMCS IPv4 addr Specifies a list of IP addresses for Broadcast and Multicast Service (BCMCS) controllers. Controllers are listed in order of preference56.
client-last-transaction-time 91 Client last transaction time Specifies the last client transaction time in units.
associated-ip 92 Associated IP Specifies that all IP addresses associated with a given DHCP client are listed.
pxe-system-type 93 PXE System Type A list of one or more 16-bit integers that allows a client to specify its pre-boot architecture type(s).
pxe-interface-id 94 Client NDI Specifies the Network Interface Identifier (NDI) for the client.
option 95 95 LDAP This option is supported if the option value type is IP, ASCII, or HEX
pxe-client-id 97 PXE client ID Allows a client to specify its PXE client identity.
uap-servers 98 User-Auth Specifies a list of URLs, each pointing to a user authentication service that is capable of processing authentication requests encapsulated in the User Authentication Protocol (UAP).

If a URL does not contain a port component, the normal default port is assumed (port 80 for http and port 443 for https).

If a URL does not include a path component, the path /uap is assumed.

option 100 100 Pcode Specifies the TZ-POSIX string used to provide timezone details.
option 101 101 Tcode Specifies the TZ-Database string used to provide timezone details.
option value 102 - 111 Removed/Unassigned These options are supported if the value type is defined as IP, ASCII, or HEX
netinfo-server-address ip-address 112 Netinfo Address This option is supported if the option value type is IP, ASCII, or HEX
netinfo-server-tag string 113 Netinfo Tag This option is supported if the option value type is IP, ASCII, or HEX
default-url 114 URL This option is supported if the option value type is IP, ASCII, or HEX
subnet-selection 118 Subnet Selection Specifies the client preferred subnet for address assignment.
domain-search 119 Domain Search Specifies a Domain Names search list used by the client to locate not-fully-qualified domain names.
vivso string 125 V-I VendorSpeciInfo Specifies Vendor-Identified vendor specific information. Only the string value is accepted.
option value 126 - 127 Removed/Unassigned These options are supported if the option value type is IP, ASCII, or HEX
option value 128 - 135 PXE-VendorSpecific These options are supported if the option value type is IP, ASCII, or HEX
option value 137 V4_LOST Specifies the fully qualified domain name (FQDN) to be used by the client to locate a Location-to-Service Translation (LoST) server.
option value 141 SIP UA Domains Specifies a list of domain names to search for Session Initiation Protocol (SIP) User Agent Configuration.
option value 142 IPv4-ANDSF Specifies the IP addresses for Access Network Discover and Selection Function (ANDSF) Servers available to the client. The servers are listed in order of priority.
option value 146 RDNSS Selection This option is supported if the option value type is IP, ASCII, or HEX
option value 147 - 148 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
tftp-server-address 150 TFTP Server Addr Specifies the address of the TFTP Server available to the client.
option value 156 dhcp-state This option is supported if the option value type is IP, ASCII, or HEX
option value 160 Captive-Portal This option is supported if the option value type is IP, ASCII, or HEX
option value 161 - 174 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
option value 175 Etherboot This option is supported if the option value type is IP, ASCII, or HEX
option value 176 IP Tele-VoiceSrvr Configures the IP telephone voice parameters for Avaya IP phones running as DHCP clients.
option value 177 PktCable-CableHome This option is supported if the option value type is IP, ASCII, or HEX
option value 178 - 206 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
option value 209 Config File Specifies the configuration file to be used in a PXELINUX environment.
option value 210 Path Prefix Specifies a path prefix for the configuration file used in a PXELINUX environment.
option value 213 V4_ACCESS_DOMAIN Specifies the access network domain name available to the client for the purposes of discovering a Local Information Server (LIS).
option value 214 - 218 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
option value 221 VSS This option is supported if the option value type is IP, ASCII, or HEX
option value 222 - 223 Unassigned These options are supported if the option value type is IP, ASCII, or HEX
option value 224 - 241 Reserved These options are supported if the option value type is IP, ASCII, or HEX
option value 242 IP Tele-DataSrvr Configures the IP telephone data parameters for Avaya IP phones running as DHCP clients.
option value 243 - 251 Reserved These options are supported if the option value type is P, ASCII, or HEX
option value 252 WPAD Configures the Proxy-Auto Config (PAC) file location string for the Web Proxy Auto-Discovery (WPAD) supported DHCP clients.
option value 253 - 254 Reserved These options are supported if the option value type is IP, ASCII, or HEX

A DHCP server assigns and manages IPv4 addresses from multiple address pools, using dynamic address allocation. The DHCP server also contains the relay agent to forward DHCP broadcast messages to network segments that do not support these types of messages.

Recommendations and Limitations

The list of supported DHCP options is extensive. However, the number of options that can be passed to the client is limited by the size of the ACK packet. It is recommended that you configure essential options only for the specific DHCP server address pool.

The following options (if configured) are prioritized, with additional options added as needed:

  • 3 - Router Option
  • 6 - Domain Name Server
  • 12 - Hostname
  • 15 - Domain name
  • 66 - TFTP server hostname or IP address
  • 67 - Boot file name
  • 60 - Vendor-Specific Information

DHCP options are not validated by the DHCP server. You must ensure the values are configured correctly.

Upgrade Considerations

In FastIron 08.0.61 or earlier releases, it was possible to configure a subset of these DHCP options using specific commands. For example, dhcp-default-router allows configuration of the DHCP default router (which is now also configurable using DHCP option 3). When upgrading to FastIron 08.0.70 or later releases, any configured DHCP options are retained. However, the configuration is stored and shown in the new options format. The following table shows the options available in earlier releases and a mapping between the current option format and the corresponding commands available in earlier releases.

Option Command Mappings between Current Formats and Previous Releases

Option Number and Name Command in Release 08.0.70 and Later Command in Release 08.0.61 and Earlier
1 - Subnet Mask network router-IP subnet mask

Note that this essential option is configured using the network command. It is not configurable using the option command.

network router-IP subnet mask
3 - Router Option option 3 ip router -IP dhcp-default-router router -IP
6 - Domain Name Server option 6 ip server-IP-address dns-server server-IP-address
12 - Hostname option 12 ascii hostname host-name hostname
15 - Domain name option 15 ascii domain-name domain-name ascii-string-domain-name
47 - NetBIOS over TCP/IP Name Server option 47 ip Server-IP netbios-name-server Server-IP
49 - X Window System Display Manager option 49 ip XWindow-manager-IP xwindow-manager XWindow-manager-IP
66 - TFTP server hostname option 66 ascii TFTP-server-hostname tftp-server TFTP-server-hostname
67 - Bootfile name option 67 ascii bootfile-name bootfile bootfile-name
150 - TFTP server IP address option 150 ip TFTP-server-IP tftp-server TFTP-server-IP
176 - ip-telephony voice server option 176 mcipadd mcport,… ip-telephony voice mcipadd mcport,…
242 - ip-telephony data server option 242 mcipadd mcport,… ip-telephony data mcipadd mcport,…
252 - Proxy-Auto Config (PAC) option 252 ascii URL-to-config-file wpad URL-to-config-file
60 - Vendor-Specific Information option 60 ascii VCI vendor-class ascii-string-VCI

Note that the existing commands are still supported. However, it is recommended that you configure these using the option command where appropriate. The configuration is stored and shown in the options format, irrespective of whether the option is configured using the option command or the commands available in previous releases.

When upgrading from any previous version to FastIron 09.0.00, the deploy and ip dhcp-server relay-agent-echo enable commands are not available and will not be seen in the running configuration after upgrade.

Follow the below process for the ISC options:

  • If the option is of type ASCII string, convert the option value to ASCII string and change the option type to "ascii".
  • If the option is of type Hex string, convert the option value to HEX string and change the option type to "hex".
  • If the option is of type integer, convert the option value as ASCII to integer, if it is a valid integer value, and save the configuration as "option <option-num> integer <option-value>", or convert the option value as hex to integer, if it is a valid integer value, and save the config as "option <option-num> integer <option-value>", or ignore the option value if it is of type IP address.
  • If the option is of type bool in 9000, convert the option value from ascii to integer; if it is a valid integer value and greater than zero, save the bool as true; if it is zero, save the bool as false. Alternatively, convert the option value from hex to integer; if it is valid integer value and greater than zero, save the bool as true; if it is zero, then save the bool as false. Another alternative is to ignore the option value if it is of type IP address.
  • If the option is of type IP address, check that the option supports the list of IPs or single IPs. If the list of IPs are supported, no change is required. If single IP is supported, save the first IP address and remove the other IP addresses. If the option is slp-service-scope, configure the bool flag as true always and save the option value as ASCII string. If the option is slp-directory-agent, configure the bool flag as true always, and save the IP addresses configured.
  • For the policy-filter(21) options, delete the option type IP. If there are three IP addresses, remove the last IP address. In FastIron 09.0.00, option 21 accepts destination IP and subnet mask as a pair. This means that option 21 configured in previous releases are not applied when upgrading to FI 09.0.00.
  • For the static-route(33) option, delete the option type IP from the command. If there are three IP addresses, remove the last IP address.